summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-05-28 17:12:42 -0500
committerMatthias Maier <tamiko@gentoo.org>2018-05-28 17:17:22 -0500
commitff2aad81bd2f8f0f1447ef358d1c803aa8e8eff6 (patch)
tree7a31446f634ec4464ab16da220454be6af04d94d /dev-util/astyle
parentdev-util/astyle: stabilize 3.0.1-r1 (diff)
downloadgentoo-ff2aad81bd2f8f0f1447ef358d1c803aa8e8eff6.tar.gz
gentoo-ff2aad81bd2f8f0f1447ef358d1c803aa8e8eff6.tar.bz2
gentoo-ff2aad81bd2f8f0f1447ef358d1c803aa8e8eff6.zip
dev-util/astyle: remove unslotted variants
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-util/astyle')
-rw-r--r--dev-util/astyle/astyle-3.0.1.ebuild85
-rw-r--r--dev-util/astyle/astyle-3.1-r1.ebuild90
2 files changed, 0 insertions, 175 deletions
diff --git a/dev-util/astyle/astyle-3.0.1.ebuild b/dev-util/astyle/astyle-3.0.1.ebuild
deleted file mode 100644
index 369eb7a23007..000000000000
--- a/dev-util/astyle/astyle-3.0.1.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils flag-o-matic toolchain-funcs versionator java-pkg-opt-2
-
-DESCRIPTION="Artistic Style is a re-indenter and reformatter for C++, C and Java source code"
-HOMEPAGE="http://astyle.sourceforge.net/"
-SRC_URI="mirror://sourceforge/astyle/astyle_${PV}_linux.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="examples java static-libs"
-
-DEPEND="app-arch/xz-utils
- java? ( >=virtual/jdk-1.6:= )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}"
-
-src_prepare() {
- if use java ; then
- java-pkg-opt-2_src_prepare
- sed -e "s:^\(JAVAINCS\s*\)=.*$:\1= $(java-pkg_get-jni-cflags):" \
- -e "s:ar crs:$(tc-getAR) crs:" \
- -i build/gcc/Makefile || die
- else
- default
- fi
-}
-
-src_configure() {
- append-cxxflags -std=c++11
- tc-export CXX
- default
-}
-
-src_compile() {
- # ../build/clang/Makefile is identical except for CXX line.
- emake CXX="$(tc-getCXX)" -f ../build/gcc/Makefile -C src \
- ${PN} \
- shared \
- $(usev java) \
- $(usex static-libs static '')
-}
-
-src_install() {
- doheader src/${PN}.h
-
- pushd src/bin >/dev/null || die
- dobin ${PN}
-
- # ex: libastyle.so.3.0.1
- dolib.so lib${PN}.so.${PV}
- # ex: libastyle.so.3
- dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so.$(get_major_version)
- if use java ; then
- dolib.so lib${PN}j.so.${PV}
- dosym lib${PN}j.so.${PV} /usr/$(get_libdir)/lib${PN}j.so.$(get_major_version)
- fi
- if use static-libs ; then
- dolib lib${PN}.a
- fi
- popd >/dev/null || die
- if use examples ; then
- docinto examples
- dodoc -r file/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
- local HTML_DOCS=( doc/. )
- einstalldocs
-}
-
-pkg_postinst() {
- if [[ -n "$REPLACING_VERSIONS" && "$(get_major_version $REPLACING_VERSIONS)" -lt 3 ]]; then
- elog "Artistic Style 3.0 introduces new configuration verbiage more fitting"
- elog "for modern use. Some options that were valid in 2.06 or older are now"
- elog "deprecated. For more information, consult astyle's release notes at"
- elog "http://astyle.sourceforge.net/news.html. To view offline, see:"
- elog
- elog "${ROOT}usr/share/doc/${P}/html"
- fi
-}
diff --git a/dev-util/astyle/astyle-3.1-r1.ebuild b/dev-util/astyle/astyle-3.1-r1.ebuild
deleted file mode 100644
index 75d605a3c894..000000000000
--- a/dev-util/astyle/astyle-3.1-r1.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic toolchain-funcs versionator java-pkg-opt-2
-
-DESCRIPTION="Artistic Style is a re-indenter and reformatter for C++, C and Java source code"
-HOMEPAGE="http://astyle.sourceforge.net/"
-SRC_URI="mirror://sourceforge/astyle/astyle_${PV}_linux.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="examples java static-libs"
-
-DEPEND="app-arch/xz-utils
- java? ( >=virtual/jdk-1.6:= )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}"
-
-src_prepare() {
- if use java ; then
- java-pkg-opt-2_src_prepare
- sed -e "s:^\(JAVAINCS\s*\)=.*$:\1= $(java-pkg_get-jni-cflags):" \
- -e "s:ar crs:$(tc-getAR) crs:" \
- -i build/gcc/Makefile || die
- else
- default
- fi
-}
-
-src_configure() {
- append-cxxflags -std=c++11
- tc-export CXX
- default
-}
-
-src_compile() {
- # ../build/clang/Makefile is identical except for CXX line.
- emake CXX="$(tc-getCXX)" -f ../build/gcc/Makefile -C src \
- ${PN} \
- shared \
- $(usev java) \
- $(usex static-libs static '')
-}
-
-src_install() {
- doheader src/${PN}.h
-
- pushd src/bin >/dev/null || die
- dobin ${PN}
-
- # ex: libastyle.so.3.0.1
- local libastylename=lib${PN}.so.${PV}.0
- dolib.so ${libastylename}
- # ex: libastyle.so.3
- local libdestdir=/usr/$(get_libdir)
- dosym ${libastylename} ${libdestdir}/lib${PN}.so.$(get_major_version)
- dosym ${libastylename} ${libdestdir}/lib${PN}.so
- if use java ; then
- local libastylejname=lib${PN}j.so.${PV}.0
- dolib.so ${libastylejname}
- dosym ${libastylejname} ${libdestdir}/lib${PN}j.so.$(get_major_version)
- dosym ${libastylejname} ${libdestdir}/lib${PN}j.so
- fi
- if use static-libs ; then
- dolib.a lib${PN}.a
- fi
- popd >/dev/null || die
- if use examples ; then
- docinto examples
- dodoc -r file/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
- local HTML_DOCS=( doc/. )
- einstalldocs
-}
-
-pkg_postinst() {
- if [[ -n "$REPLACING_VERSIONS" && "$(get_major_version $REPLACING_VERSIONS)" -lt 3 ]]; then
- elog "Artistic Style 3.0 introduces new configuration verbiage more fitting"
- elog "for modern use. Some options that were valid in 2.06 or older are now"
- elog "deprecated. For more information, consult astyle's release notes at"
- elog "http://astyle.sourceforge.net/news.html. To view offline, see:"
- elog
- elog "${EROOT%/}/usr/share/doc/${P}/html"
- fi
-}