summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2021-03-16 21:16:52 +0100
committerSam James <sam@gentoo.org>2021-03-16 21:28:23 +0000
commitef296343ba694a313457c2ba7d6af696c0c5c78e (patch)
tree69e097a737458d4e395adeeae308adf88fa83b3b /dev-util/bats/bats-1.3.0.ebuild
parentapp-admin/verynice: add myself to maintainers (diff)
downloadgentoo-ef296343ba694a313457c2ba7d6af696c0c5c78e.tar.gz
gentoo-ef296343ba694a313457c2ba7d6af696c0c5c78e.tar.bz2
gentoo-ef296343ba694a313457c2ba7d6af696c0c5c78e.zip
dev-util/bats: bump version to 1.3.0
Signed-off-by: Henning Schild <henning@hennsch.de> Closes: https://github.com/gentoo/gentoo/pull/19962 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/bats/bats-1.3.0.ebuild')
-rw-r--r--dev-util/bats/bats-1.3.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/bats/bats-1.3.0.ebuild b/dev-util/bats/bats-1.3.0.ebuild
new file mode 100644
index 000000000000..0cc0631f5528
--- /dev/null
+++ b/dev-util/bats/bats-1.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature
+
+MY_PN="bats-core"
+DESCRIPTION="Bats-core: Bash Automated Testing System"
+HOMEPAGE="https://github.com/bats-core/bats-core/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND="app-shells/bash:*"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_test() {
+ bin/bats --tap test || die "Tests failed"
+}
+
+src_install() {
+ exeinto /usr/libexec/${MY_PN}
+ doexe libexec/${MY_PN}/*
+ exeinto /usr/lib/${MY_PN}
+ doexe lib/${MY_PN}/*
+ dobin bin/${PN}
+
+ dodoc README.md
+ doman man/${PN}.1 man/${PN}.7
+}
+
+pkg_postinst() {
+ optfeature "Parallel Execution" sys-process/parallel
+}