summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2018-05-21 10:57:24 -0700
committerZac Medico <zmedico@gentoo.org>2018-05-21 11:10:44 -0700
commit441d853f5076a066ca9d6901a01158191a3208a2 (patch)
treeddb91ccb4143e0af4fad8256361f4d45a8bd34b0 /dev-util/bazel/bazel-0.7.0.ebuild
parentbzr.eclass: Support EAPI 7. (diff)
downloadgentoo-441d853f5076a066ca9d6901a01158191a3208a2.tar.gz
gentoo-441d853f5076a066ca9d6901a01158191a3208a2.tar.bz2
gentoo-441d853f5076a066ca9d6901a01158191a3208a2.zip
dev-util/bazel: make build respect MAKEOPTS
Bug: https://bugs.gentoo.org/652776 Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'dev-util/bazel/bazel-0.7.0.ebuild')
-rw-r--r--dev-util/bazel/bazel-0.7.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-util/bazel/bazel-0.7.0.ebuild b/dev-util/bazel/bazel-0.7.0.ebuild
index 4684dc2d3b48..0a5efcceeb51 100644
--- a/dev-util/bazel/bazel-0.7.0.ebuild
+++ b/dev-util/bazel/bazel-0.7.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit bash-completion-r1 java-pkg-2
+inherit bash-completion-r1 java-pkg-2 multiprocessing
DESCRIPTION="Fast and correct automated build system"
HOMEPAGE="http://bazel.io/"
@@ -36,11 +36,12 @@ src_compile() {
# R: /proc/24939/setgroups
# C: /usr/lib/systemd/systemd
addpredict /proc
+ export EXTRA_BAZEL_ARGS="--jobs=$(makeopts_jobs)"
VERBOSE=yes ./compile.sh || die
# Use standalone strategy to deactivate the bazel sandbox, since it
# conflicts with FEATURES=sandbox.
echo "build --verbose_failures --spawn_strategy=standalone --genrule_strategy=standalone" \
- > "${T}/bazelrc" || die
+ "--jobs=$(makeopts_jobs)" > "${T}/bazelrc" || die
output/bazel --bazelrc="${T}/bazelrc" build scripts:bazel-complete.bash || die
mv bazel-bin/scripts/bazel-complete.bash output/ || die
}