summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyangWu <xgreenlandforwyy@gmail.com>2021-08-27 17:20:54 +0800
committerBenda Xu <heroxbd@gentoo.org>2021-11-06 12:47:48 +0800
commita14ecad8b352b82ab925546099a4014649338e08 (patch)
treee027e8fe672c0ce489d6a01ae7c98bcaceb1a09f /dev-util/bazel
parentsys-apps/input-utils: use 'emake', not 'make' (diff)
downloadgentoo-a14ecad8b352b82ab925546099a4014649338e08.tar.gz
gentoo-a14ecad8b352b82ab925546099a4014649338e08.tar.bz2
gentoo-a14ecad8b352b82ab925546099a4014649338e08.zip
dev-util/bazel: remove hack for Gentoo prefix
In bazel-3.2 prefix and static-libs use flag is added concerning bug #773982 For bazel-3.7 the issue is gone and specifying static link flags causes build error. Closes: https://github.com/gentoo/gentoo/pull/22126 Bugs: https://bugs.gentoo.org/773982 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'dev-util/bazel')
-rw-r--r--dev-util/bazel/bazel-3.7.2-r1.ebuild (renamed from dev-util/bazel/bazel-3.7.2.ebuild)6
1 files changed, 1 insertions, 5 deletions
diff --git a/dev-util/bazel/bazel-3.7.2.ebuild b/dev-util/bazel/bazel-3.7.2-r1.ebuild
index 8f687a47d16b..161e10ad821a 100644
--- a/dev-util/bazel/bazel-3.7.2.ebuild
+++ b/dev-util/bazel/bazel-3.7.2-r1.ebuild
@@ -13,8 +13,7 @@ SRC_URI="https://github.com/bazelbuild/bazel/releases/download/${PV}/${P}-dist.z
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="examples tools prefix static-libs"
-REQUIRED_USE="prefix? ( static-libs )"
+IUSE="examples tools"
# strip corrupts the bazel binary
# test fails with network-sandbox: An error occurred during the fetch of repository 'io_bazel_skydoc' (bug 690794)
RESTRICT="strip test"
@@ -71,9 +70,6 @@ src_prepare() {
src_compile() {
export EXTRA_BAZEL_ARGS="--jobs=$(makeopts_jobs) $(bazel-get-flags) --host_javabase=@local_jdk//:jdk"
- if use static-libs; then
- export BAZEL_LINKOPTS=-static-libs:-static-libgcc BAZEL_LINKLIBS=-l%:libstdc++.a:-lm
- fi
VERBOSE=yes ./compile.sh || die
./scripts/generate_bash_completion.sh \