summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-04-18 10:08:18 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-04-18 10:33:52 -0700
commitdf53b0c7cb0d77a3534a9a019f4eaf59483461e3 (patch)
tree9bacd927a1a6e72061b7e05fee93ae52543cdda1 /dev-util/bcc
parentdev-ruby/shoulda-matchers: add 5.1.0 (diff)
downloadgentoo-df53b0c7cb0d77a3534a9a019f4eaf59483461e3.tar.gz
gentoo-df53b0c7cb0d77a3534a9a019f4eaf59483461e3.tar.bz2
gentoo-df53b0c7cb0d77a3534a9a019f4eaf59483461e3.zip
dev-util/bcc: 0.24.0-r1 drop py3.7, add LLVM 14 support
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-util/bcc')
-rw-r--r--dev-util/bcc/bcc-0.24.0-r1.ebuild (renamed from dev-util/bcc/bcc-0.24.0.ebuild)10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-util/bcc/bcc-0.24.0.ebuild b/dev-util/bcc/bcc-0.24.0-r1.ebuild
index ffaf9d8d99ff..86a3d50ede4f 100644
--- a/dev-util/bcc/bcc-0.24.0.ebuild
+++ b/dev-util/bcc/bcc-0.24.0-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
LUA_COMPAT=( luajit )
-PYTHON_COMPAT=( python3_{7..10} )
-LLVM_MAX_SLOT=13
+PYTHON_COMPAT=( python3_{8..10} )
+LLVM_MAX_SLOT=14
-inherit cmake eapi8-dosym linux-info llvm lua-single python-r1 toolchain-funcs
+inherit cmake linux-info llvm lua-single python-r1 toolchain-funcs
DESCRIPTION="Tools for BPF-based Linux IO analysis, networking, monitoring, and more"
HOMEPAGE="https://iovisor.github.io/bcc/"
@@ -126,7 +126,7 @@ src_install() {
[[ ! -x ${tool} && ! -L ${tool} || -d ${tool} ]] && continue
name=${tool##*/}
[[ -n ${rename_tools[${name}]} ]] && name=bcc-${name}
- dosym8 -r "${tool#${ED}}" /usr/sbin/${name}
+ dosym -r "${tool#${ED}}" /usr/sbin/${name}
done
docompress /usr/share/${PN}/man