summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-08-15 22:54:08 +1000
committerDavid Seifert <soap@gentoo.org>2020-08-16 01:19:03 +0200
commit5f5f811457168d6072bb301086e16cbfbaea7419 (patch)
treea34a799fbaf88211b6a29460085b1d29bf142ab7 /dev-util/boost-build/boost-build-1.74.0.ebuild
parentsys-kernel/genkernel: rollover keywords (diff)
downloadgentoo-5f5f811457168d6072bb301086e16cbfbaea7419.tar.gz
gentoo-5f5f811457168d6072bb301086e16cbfbaea7419.tar.bz2
gentoo-5f5f811457168d6072bb301086e16cbfbaea7419.zip
dev-util/boost-build: Bump to 1.74.0
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Mark Wright <gienah@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-util/boost-build/boost-build-1.74.0.ebuild')
-rw-r--r--dev-util/boost-build/boost-build-1.74.0.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/dev-util/boost-build/boost-build-1.74.0.ebuild b/dev-util/boost-build/boost-build-1.74.0.ebuild
new file mode 100644
index 000000000000..40e1b4993f78
--- /dev/null
+++ b/dev-util/boost-build/boost-build-1.74.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic prefix toolchain-funcs
+
+MY_PV="$(ver_rs 1- _)"
+
+DESCRIPTION="A system for large project software construction, simple to use and powerful"
+HOMEPAGE="https://boostorg.github.io/build/"
+SRC_URI="https://dl.bintray.com/boostorg/release/${PV}/source/boost_${MY_PV}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples"
+RESTRICT="test"
+
+S="${WORKDIR}/boost_${MY_PV}/tools/build/src"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.71.0-disable_python_rpath.patch
+ "${FILESDIR}"/${PN}-1.71.0-darwin-gentoo-toolchain.patch
+ "${FILESDIR}"/${PN}-1.73.0-add-none-feature-options.patch
+ "${FILESDIR}"/${PN}-1.71.0-respect-c_ld-flags.patch
+ "${FILESDIR}"/${PN}-1.74.0-no-implicit-march-flags.patch
+)
+
+src_unpack() {
+ tar xojf "${DISTDIR}/${A}" boost_${MY_PV}/tools/build || die "unpacking tar failed"
+}
+
+src_prepare() {
+ default
+
+ pushd .. >/dev/null || die
+ eapply "${FILESDIR}"/${PN}-1.71.0-fix-test.patch
+ popd >/dev/null || die
+}
+
+src_configure() {
+ hprefixify engine/Jambase
+ tc-export CXX
+}
+
+src_compile() {
+ cd engine || die
+ ./build.sh cxx -d+2 --without-python || die "building bjam failed"
+}
+
+src_test() {
+ # Forget tests, bjam is a lost cause
+ :
+}
+
+src_install() {
+ dobin engine/{bjam,b2}
+
+ insinto /usr/share/boost-build
+ doins -r "${FILESDIR}/site-config.jam" \
+ ../boost-build.jam bootstrap.jam build-system.jam ../example/user-config.jam *.py \
+ build kernel options tools util
+
+ find "${ED}"/usr/share/boost-build -iname '*.py' -delete || die
+
+ dodoc ../notes/{changes,release_procedure,build_dir_option,relative_source_paths}.txt
+
+ if use examples; then
+ docinto examples
+ dodoc -r ../example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}