summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-05-08 15:15:33 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-05-08 15:23:41 +0200
commit6b7c1c948b8b7b790a072b82dcb2b08c90e8717c (patch)
treecaef9f4f0fe1a50c69ebaa160d1d5014362e2a5a /dev-util/boost-build
parentdev-libs/boost: Drop 1.77.0-r4 (diff)
downloadgentoo-6b7c1c948b8b7b790a072b82dcb2b08c90e8717c.tar.gz
gentoo-6b7c1c948b8b7b790a072b82dcb2b08c90e8717c.tar.bz2
gentoo-6b7c1c948b8b7b790a072b82dcb2b08c90e8717c.zip
dev-util/boost-build: Drop 1.77.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util/boost-build')
-rw-r--r--dev-util/boost-build/Manifest1
-rw-r--r--dev-util/boost-build/boost-build-1.77.0.ebuild73
-rw-r--r--dev-util/boost-build/files/boost-build-1.74.0-no-implicit-march-flags.patch279
-rw-r--r--dev-util/boost-build/files/boost-build-1.77.0-darwin-gentoo-toolchain.patch26
4 files changed, 0 insertions, 379 deletions
diff --git a/dev-util/boost-build/Manifest b/dev-util/boost-build/Manifest
index 227b3173730a..dda317544a26 100644
--- a/dev-util/boost-build/Manifest
+++ b/dev-util/boost-build/Manifest
@@ -1,3 +1,2 @@
-DIST boost_1_77_0.tar.bz2 110361537 BLAKE2B 106aeb09ec7705b595f2ca966a76c53c649eac6fac50d88c156862e0991c33c89a2f3a09edcbcb453fa44bf71cdde030b35d0a0889ad97b65f3a868cb877a532 SHA512 39b45c9b60bc5a2a4c669a4463d1272c1e093376b2fb374d7f20a84ea10a3e23bb04b335a735a83a04575731f874d9bff77e89acd947524b3fbbae1b26ae1f2f
DIST boost_1_78_0.tar.bz2 110675550 BLAKE2B ed7da98862ec1e0a28472544400e6f44ffadbc967eed969ce6cb62b1c4f0b7a4b98a395269eb374b57326eff9cdb1dd6e47df9d1a9730aff7c926cc44388fb2d SHA512 9c34a387a203b99aa773eb0c59f5abac7a99ba10e4623653e793c1d5b29b99b88e0e4e0d4e2e4ca5d497c42f2e46e23bab66417722433a457dc818d7670bcbbf
DIST boost_1_79_0.tar.bz2 113456811 BLAKE2B 61f47ca022e60745868e6bdd3b5c75603dd68d878e126dcbb73de5b40fc03c0eec8eede3ec304ece58050435ef2fc1ed7eb763773c20673f85e32bbf4d5f978a SHA512 70909e0561c213d10a1fdd692f9ae7b293d3cdc63e925bdc207da9e9bba6e86474341100e7ee5de6d94f9561196b1a3a1597055a7b7382babf8931131170a312
diff --git a/dev-util/boost-build/boost-build-1.77.0.ebuild b/dev-util/boost-build/boost-build-1.77.0.ebuild
deleted file mode 100644
index af86a0c414e2..000000000000
--- a/dev-util/boost-build/boost-build-1.77.0.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic toolchain-funcs
-
-MY_PV="$(ver_rs 1- _)"
-
-DESCRIPTION="A system for large project software construction, simple to use and powerful"
-HOMEPAGE="https://www.boost.org/build/"
-SRC_URI="https://boostorg.jfrog.io/artifactory/main/release/${PV}/source/boost_${MY_PV}.tar.bz2"
-S="${WORKDIR}/boost_${MY_PV}/tools/build/src"
-
-LICENSE="Boost-1.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="examples"
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.71.0-disable_python_rpath.patch
- "${FILESDIR}"/${PN}-1.77.0-darwin-gentoo-toolchain.patch
- "${FILESDIR}"/${PN}-1.73.0-add-none-feature-options.patch
- "${FILESDIR}"/${PN}-1.76.0-respect-user-flags.patch
- "${FILESDIR}"/${PN}-1.74.0-no-implicit-march-flags.patch
-)
-
-src_unpack() {
- tar xojf "${DISTDIR}/${A}" boost_${MY_PV}/tools/build || die "unpacking tar failed"
-}
-
-src_prepare() {
- default
-
- pushd .. >/dev/null || die
- eapply "${FILESDIR}"/${PN}-1.71.0-fix-test.patch
- popd >/dev/null || die
-}
-
-src_configure() {
- # need to enable LFS explicitly for 64-bit offsets on 32-bit hosts (#761100)
- append-lfs-flags
-}
-
-src_compile() {
- cd engine || die
- ${CONFIG_SHELL:-${BASH}} ./build.sh cxx --cxx="$(tc-getCXX)" --cxxflags="${CXXFLAGS}" -d+2 --without-python || die "building bjam failed"
-}
-
-src_test() {
- # Forget tests, bjam is a lost cause
- :
-}
-
-src_install() {
- dobin engine/{bjam,b2}
-
- insinto /usr/share/boost-build/src
- doins -r "${FILESDIR}/site-config.jam" \
- ../boost-build.jam bootstrap.jam build-system.jam ../example/user-config.jam *.py \
- build kernel options tools util
-
- find "${ED}"/usr/share/boost-build/src -iname '*.py' -delete || die
-
- dodoc ../notes/{changes,release_procedure,build_dir_option,relative_source_paths}.txt
-
- if use examples; then
- docinto examples
- dodoc -r ../example/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-util/boost-build/files/boost-build-1.74.0-no-implicit-march-flags.patch b/dev-util/boost-build/files/boost-build-1.74.0-no-implicit-march-flags.patch
deleted file mode 100644
index 894af8f62c2d..000000000000
--- a/dev-util/boost-build/files/boost-build-1.74.0-no-implicit-march-flags.patch
+++ /dev/null
@@ -1,279 +0,0 @@
---- a/tools/gcc.jam
-+++ b/tools/gcc.jam
-@@ -1224,135 +1224,9 @@
- # x86 and compatible
- # The 'native' option appeared in gcc 4.2 so we cannot safely use it as default.
- # Use i686 instead for 32-bit.
--toolset.flags gcc OPTIONS <architecture>x86/<address-model>32/<instruction-set> : -march=i686 ;
--cpu-flags gcc OPTIONS : x86 : native : -march=native ;
--cpu-flags gcc OPTIONS : x86 : i486 : -march=i486 ;
--cpu-flags gcc OPTIONS : x86 : i586 : -march=i586 ;
--cpu-flags gcc OPTIONS : x86 : i686 : -march=i686 ;
--cpu-flags gcc OPTIONS : x86 : pentium : -march=pentium ;
--cpu-flags gcc OPTIONS : x86 : pentium-mmx : -march=pentium-mmx ;
--cpu-flags gcc OPTIONS : x86 : pentiumpro : -march=pentiumpro ;
--cpu-flags gcc OPTIONS : x86 : pentium2 : -march=pentium2 ;
--cpu-flags gcc OPTIONS : x86 : pentium3 : -march=pentium3 ;
--cpu-flags gcc OPTIONS : x86 : pentium3m : -march=pentium3m ;
--cpu-flags gcc OPTIONS : x86 : pentium-m : -march=pentium-m ;
--cpu-flags gcc OPTIONS : x86 : pentium4 : -march=pentium4 ;
--cpu-flags gcc OPTIONS : x86 : pentium4m : -march=pentium4m ;
--cpu-flags gcc OPTIONS : x86 : prescott : -march=prescott ;
--cpu-flags gcc OPTIONS : x86 : nocona : -march=nocona ;
--cpu-flags gcc OPTIONS : x86 : core2 : -march=core2 ;
--cpu-flags gcc OPTIONS : x86 : conroe : -march=core2 ;
--cpu-flags gcc OPTIONS : x86 : conroe-xe : -march=core2 ;
--cpu-flags gcc OPTIONS : x86 : conroe-l : -march=core2 ;
--cpu-flags gcc OPTIONS : x86 : allendale : -march=core2 ;
--cpu-flags gcc OPTIONS : x86 : wolfdale : -march=core2 -msse4.1 ;
--cpu-flags gcc OPTIONS : x86 : merom : -march=core2 ;
--cpu-flags gcc OPTIONS : x86 : merom-xe : -march=core2 ;
--cpu-flags gcc OPTIONS : x86 : kentsfield : -march=core2 ;
--cpu-flags gcc OPTIONS : x86 : kentsfield-xe : -march=core2 ;
--cpu-flags gcc OPTIONS : x86 : yorksfield : -march=core2 ;
--cpu-flags gcc OPTIONS : x86 : penryn : -march=core2 ;
--cpu-flags gcc OPTIONS : x86 : corei7 : -march=corei7 ;
--cpu-flags gcc OPTIONS : x86 : nehalem : -march=corei7 ;
--cpu-flags gcc OPTIONS : x86 : corei7-avx : -march=corei7-avx ;
--cpu-flags gcc OPTIONS : x86 : sandy-bridge : -march=corei7-avx ;
--cpu-flags gcc OPTIONS : x86 : core-avx-i : -march=core-avx-i ;
--cpu-flags gcc OPTIONS : x86 : ivy-bridge : -march=core-avx-i ;
--cpu-flags gcc OPTIONS : x86 : haswell : -march=core-avx-i -mavx2 -mfma -mbmi -mbmi2 -mlzcnt ;
--cpu-flags gcc OPTIONS : x86 : broadwell : -march=broadwell ;
--cpu-flags gcc OPTIONS : x86 : skylake : -march=skylake ;
--cpu-flags gcc OPTIONS : x86 : skylake-avx512 : -march=skylake-avx512 ;
--cpu-flags gcc OPTIONS : x86 : cannonlake : -march=skylake-avx512 -mavx512vbmi -mavx512ifma -msha ;
--cpu-flags gcc OPTIONS : x86 : icelake-client : -march=icelake-client ;
--cpu-flags gcc OPTIONS : x86 : icelake-server : -march=icelake-server ;
--cpu-flags gcc OPTIONS : x86 : cascadelake : -march=skylake-avx512 -mavx512vnni ;
--cpu-flags gcc OPTIONS : x86 : cooperlake : -march=cooperlake ;
--cpu-flags gcc OPTIONS : x86 : tigerlake : -march=tigerlake ;
--cpu-flags gcc OPTIONS : x86 : k6 : -march=k6 ;
--cpu-flags gcc OPTIONS : x86 : k6-2 : -march=k6-2 ;
--cpu-flags gcc OPTIONS : x86 : k6-3 : -march=k6-3 ;
--cpu-flags gcc OPTIONS : x86 : athlon : -march=athlon ;
--cpu-flags gcc OPTIONS : x86 : athlon-tbird : -march=athlon-tbird ;
--cpu-flags gcc OPTIONS : x86 : athlon-4 : -march=athlon-4 ;
--cpu-flags gcc OPTIONS : x86 : athlon-xp : -march=athlon-xp ;
--cpu-flags gcc OPTIONS : x86 : athlon-mp : -march=athlon-mp ;
- ##
--cpu-flags gcc OPTIONS : x86 : k8 : -march=k8 ;
--cpu-flags gcc OPTIONS : x86 : opteron : -march=opteron ;
--cpu-flags gcc OPTIONS : x86 : athlon64 : -march=athlon64 ;
--cpu-flags gcc OPTIONS : x86 : athlon-fx : -march=athlon-fx ;
--cpu-flags gcc OPTIONS : x86 : k8-sse3 : -march=k8-sse3 ;
--cpu-flags gcc OPTIONS : x86 : opteron-sse3 : -march=opteron-sse3 ;
--cpu-flags gcc OPTIONS : x86 : athlon64-sse3 : -march=athlon64-sse3 ;
--cpu-flags gcc OPTIONS : x86 : amdfam10 : -march=amdfam10 ;
--cpu-flags gcc OPTIONS : x86 : barcelona : -march=barcelona ;
--cpu-flags gcc OPTIONS : x86 : bdver1 : -march=bdver1 ;
--cpu-flags gcc OPTIONS : x86 : bdver2 : -march=bdver2 ;
--cpu-flags gcc OPTIONS : x86 : bdver3 : -march=bdver3 ;
--cpu-flags gcc OPTIONS : x86 : bdver4 : -march=bdver4 ;
--cpu-flags gcc OPTIONS : x86 : btver1 : -march=btver1 ;
--cpu-flags gcc OPTIONS : x86 : btver2 : -march=btver2 ;
--cpu-flags gcc OPTIONS : x86 : znver1 : -march=znver1 ;
--cpu-flags gcc OPTIONS : x86 : znver2 : -march=znver2 ;
--cpu-flags gcc OPTIONS : x86 : winchip-c6 : -march=winchip-c6 ;
--cpu-flags gcc OPTIONS : x86 : winchip2 : -march=winchip2 ;
--cpu-flags gcc OPTIONS : x86 : c3 : -march=c3 ;
--cpu-flags gcc OPTIONS : x86 : c3-2 : -march=c3-2 ;
--cpu-flags gcc OPTIONS : x86 : c7 : -march=c7 ;
- ##
--cpu-flags gcc OPTIONS : x86 : atom : -march=atom ;
- # Sparc
--cpu-flags gcc OPTIONS : sparc : v7 : -mcpu=v7 : default ;
--cpu-flags gcc OPTIONS : sparc : cypress : -mcpu=cypress ;
--cpu-flags gcc OPTIONS : sparc : v8 : -mcpu=v8 ;
--cpu-flags gcc OPTIONS : sparc : supersparc : -mcpu=supersparc ;
--cpu-flags gcc OPTIONS : sparc : sparclite : -mcpu=sparclite ;
--cpu-flags gcc OPTIONS : sparc : hypersparc : -mcpu=hypersparc ;
--cpu-flags gcc OPTIONS : sparc : sparclite86x : -mcpu=sparclite86x ;
--cpu-flags gcc OPTIONS : sparc : f930 : -mcpu=f930 ;
--cpu-flags gcc OPTIONS : sparc : f934 : -mcpu=f934 ;
--cpu-flags gcc OPTIONS : sparc : sparclet : -mcpu=sparclet ;
--cpu-flags gcc OPTIONS : sparc : tsc701 : -mcpu=tsc701 ;
--cpu-flags gcc OPTIONS : sparc : v9 : -mcpu=v9 ;
--cpu-flags gcc OPTIONS : sparc : ultrasparc : -mcpu=ultrasparc ;
--cpu-flags gcc OPTIONS : sparc : ultrasparc3 : -mcpu=ultrasparc3 ;
- # RS/6000 & PowerPC
--cpu-flags gcc OPTIONS : power : 403 : -mcpu=403 ;
--cpu-flags gcc OPTIONS : power : 505 : -mcpu=505 ;
--cpu-flags gcc OPTIONS : power : 601 : -mcpu=601 ;
--cpu-flags gcc OPTIONS : power : 602 : -mcpu=602 ;
--cpu-flags gcc OPTIONS : power : 603 : -mcpu=603 ;
--cpu-flags gcc OPTIONS : power : 603e : -mcpu=603e ;
--cpu-flags gcc OPTIONS : power : 604 : -mcpu=604 ;
--cpu-flags gcc OPTIONS : power : 604e : -mcpu=604e ;
--cpu-flags gcc OPTIONS : power : 620 : -mcpu=620 ;
--cpu-flags gcc OPTIONS : power : 630 : -mcpu=630 ;
--cpu-flags gcc OPTIONS : power : 740 : -mcpu=740 ;
--cpu-flags gcc OPTIONS : power : 7400 : -mcpu=7400 ;
--cpu-flags gcc OPTIONS : power : 7450 : -mcpu=7450 ;
--cpu-flags gcc OPTIONS : power : 750 : -mcpu=750 ;
--cpu-flags gcc OPTIONS : power : 801 : -mcpu=801 ;
--cpu-flags gcc OPTIONS : power : 821 : -mcpu=821 ;
--cpu-flags gcc OPTIONS : power : 823 : -mcpu=823 ;
--cpu-flags gcc OPTIONS : power : 860 : -mcpu=860 ;
--cpu-flags gcc OPTIONS : power : 970 : -mcpu=970 ;
--cpu-flags gcc OPTIONS : power : 8540 : -mcpu=8540 ;
--cpu-flags gcc OPTIONS : power : power : -mcpu=power ;
--cpu-flags gcc OPTIONS : power : power2 : -mcpu=power2 ;
--cpu-flags gcc OPTIONS : power : power3 : -mcpu=power3 ;
--cpu-flags gcc OPTIONS : power : power4 : -mcpu=power4 ;
--cpu-flags gcc OPTIONS : power : power5 : -mcpu=power5 ;
--cpu-flags gcc OPTIONS : power : powerpc : -mcpu=powerpc ;
--cpu-flags gcc OPTIONS : power : powerpc64 : -mcpu=powerpc64 ;
--cpu-flags gcc OPTIONS : power : rios : -mcpu=rios ;
--cpu-flags gcc OPTIONS : power : rios1 : -mcpu=rios1 ;
--cpu-flags gcc OPTIONS : power : rios2 : -mcpu=rios2 ;
--cpu-flags gcc OPTIONS : power : rsc : -mcpu=rsc ;
--cpu-flags gcc OPTIONS : power : rs64a : -mcpu=rs64 ;
--cpu-flags gcc OPTIONS : s390x : z196 : -march=z196 ;
--cpu-flags gcc OPTIONS : s390x : zEC12 : -march=zEC12 ;
--cpu-flags gcc OPTIONS : s390x : z13 : -march=z13 ;
--cpu-flags gcc OPTIONS : s390x : z14 : -march=z14 ;
--cpu-flags gcc OPTIONS : s390x : z15 : -march=z15 ;
- # AIX variant of RS/6000 & PowerPC
- toolset.flags gcc AROPTIONS <address-model>64/<target-os>aix : "-X64" ;
---- a/tools/gcc.py
-+++ b/tools/gcc.py
-@@ -745,138 +745,14 @@
- # x86 and compatible
- flags('gcc', 'OPTIONS', ['<architecture>x86/<address-model>32'], ['-m32'])
- flags('gcc', 'OPTIONS', ['<architecture>x86/<address-model>64'], ['-m64'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'native', ['-march=native'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'i486', ['-march=i486'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'i586', ['-march=i586'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'i686', ['-march=i686'], default=True)
--cpu_flags('gcc', 'OPTIONS', 'x86', 'pentium', ['-march=pentium'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'pentium-mmx', ['-march=pentium-mmx'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'pentiumpro', ['-march=pentiumpro'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'pentium2', ['-march=pentium2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'pentium3', ['-march=pentium3'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'pentium3m', ['-march=pentium3m'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'pentium-m', ['-march=pentium-m'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'pentium4', ['-march=pentium4'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'pentium4m', ['-march=pentium4m'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'prescott', ['-march=prescott'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'nocona', ['-march=nocona'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'core2', ['-march=core2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'conroe', ['-march=core2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'conroe-xe', ['-march=core2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'conroe-l', ['-march=core2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'allendale', ['-march=core2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'wolfdale', ['-march=core2', '-msse4.1'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'merom', ['-march=core2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'merom-xe', ['-march=core2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'kentsfield', ['-march=core2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'kentsfield-xe', ['-march=core2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'yorksfield', ['-march=core2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'penryn', ['-march=core2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'corei7', ['-march=corei7'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'nehalem', ['-march=corei7'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'corei7-avx', ['-march=corei7-avx'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'sandy-bridge', ['-march=corei7-avx'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'core-avx-i', ['-march=core-avx-i'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'ivy-bridge', ['-march=core-avx-i'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'haswell', ['-march=core-avx-i', '-mavx2', '-mfma', '-mbmi', '-mbmi2', '-mlzcnt'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'broadwell', ['-march=broadwell'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'skylake', ['-march=skylake'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'skylake-avx512', ['-march=skylake-avx512'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'cannonlake', ['-march=skylake-avx512', '-mavx512vbmi', '-mavx512ifma', '-msha'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'icelake-client', ['-march=icelake-client'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'icelake-server', ['-march=icelake-server'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'cascadelake', ['-march=skylake-avx512', '-mavx512vnni'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'cooperlake', ['-march=cooperlake'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'tigerlake', ['-march=tigerlake'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'k6', ['-march=k6'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'k6-2', ['-march=k6-2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'k6-3', ['-march=k6-3'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'athlon', ['-march=athlon'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'athlon-tbird', ['-march=athlon-tbird'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'athlon-4', ['-march=athlon-4'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'athlon-xp', ['-march=athlon-xp'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'athlon-mp', ['-march=athlon-mp'])
- ##
--cpu_flags('gcc', 'OPTIONS', 'x86', 'k8', ['-march=k8'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'opteron', ['-march=opteron'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'athlon64', ['-march=athlon64'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'athlon-fx', ['-march=athlon-fx'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'k8-sse3', ['-march=k8-sse3'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'opteron-sse3', ['-march=opteron-sse3'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'athlon64-sse3', ['-march=athlon64-sse3'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'amdfam10', ['-march=amdfam10'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'barcelona', ['-march=barcelona'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'bdver1', ['-march=bdver1'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'bdver2', ['-march=bdver2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'bdver3', ['-march=bdver3'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'btver1', ['-march=btver1'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'btver2', ['-march=btver2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'znver1', ['-march=znver1'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'znver2', ['-march=znver2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'winchip-c6', ['-march=winchip-c6'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'winchip2', ['-march=winchip2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'c3', ['-march=c3'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'c3-2', ['-march=c3-2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'c7', ['-march=c7'])
- ##
--cpu_flags('gcc', 'OPTIONS', 'x86', 'atom', ['-march=atom'])
- # Sparc
- flags('gcc', 'OPTIONS', ['<architecture>sparc/<address-model>32'], ['-m32'])
- flags('gcc', 'OPTIONS', ['<architecture>sparc/<address-model>64'], ['-m64'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'v7', ['-mcpu=v7'], default=True)
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'cypress', ['-mcpu=cypress'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'v8', ['-mcpu=v8'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'supersparc', ['-mcpu=supersparc'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'sparclite', ['-mcpu=sparclite'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'hypersparc', ['-mcpu=hypersparc'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'sparclite86x', ['-mcpu=sparclite86x'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'f930', ['-mcpu=f930'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'f934', ['-mcpu=f934'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'sparclet', ['-mcpu=sparclet'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'tsc701', ['-mcpu=tsc701'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'v9', ['-mcpu=v9'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'ultrasparc', ['-mcpu=ultrasparc'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'ultrasparc3', ['-mcpu=ultrasparc3'])
- # RS/6000 & PowerPC
- flags('gcc', 'OPTIONS', ['<architecture>power/<address-model>32'], ['-m32'])
- flags('gcc', 'OPTIONS', ['<architecture>power/<address-model>64'], ['-m64'])
--cpu_flags('gcc', 'OPTIONS', 'power', '403', ['-mcpu=403'])
--cpu_flags('gcc', 'OPTIONS', 'power', '505', ['-mcpu=505'])
--cpu_flags('gcc', 'OPTIONS', 'power', '601', ['-mcpu=601'])
--cpu_flags('gcc', 'OPTIONS', 'power', '602', ['-mcpu=602'])
--cpu_flags('gcc', 'OPTIONS', 'power', '603', ['-mcpu=603'])
--cpu_flags('gcc', 'OPTIONS', 'power', '603e', ['-mcpu=603e'])
--cpu_flags('gcc', 'OPTIONS', 'power', '604', ['-mcpu=604'])
--cpu_flags('gcc', 'OPTIONS', 'power', '604e', ['-mcpu=604e'])
--cpu_flags('gcc', 'OPTIONS', 'power', '620', ['-mcpu=620'])
--cpu_flags('gcc', 'OPTIONS', 'power', '630', ['-mcpu=630'])
--cpu_flags('gcc', 'OPTIONS', 'power', '740', ['-mcpu=740'])
--cpu_flags('gcc', 'OPTIONS', 'power', '7400', ['-mcpu=7400'])
--cpu_flags('gcc', 'OPTIONS', 'power', '7450', ['-mcpu=7450'])
--cpu_flags('gcc', 'OPTIONS', 'power', '750', ['-mcpu=750'])
--cpu_flags('gcc', 'OPTIONS', 'power', '801', ['-mcpu=801'])
--cpu_flags('gcc', 'OPTIONS', 'power', '821', ['-mcpu=821'])
--cpu_flags('gcc', 'OPTIONS', 'power', '823', ['-mcpu=823'])
--cpu_flags('gcc', 'OPTIONS', 'power', '860', ['-mcpu=860'])
--cpu_flags('gcc', 'OPTIONS', 'power', '970', ['-mcpu=970'])
--cpu_flags('gcc', 'OPTIONS', 'power', '8540', ['-mcpu=8540'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'power', ['-mcpu=power'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'power2', ['-mcpu=power2'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'power3', ['-mcpu=power3'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'power4', ['-mcpu=power4'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'power5', ['-mcpu=power5'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'powerpc', ['-mcpu=powerpc'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'powerpc64', ['-mcpu=powerpc64'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'rios', ['-mcpu=rios'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'rios1', ['-mcpu=rios1'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'rios2', ['-mcpu=rios2'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'rsc', ['-mcpu=rsc'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'rs64a', ['-mcpu=rs64'])
--cpu_flags('gcc', 'OPTIONS', 's390x', 'z196', ['-march=z196'])
--cpu_flags('gcc', 'OPTIONS', 's390x', 'zEC12', ['-march=zEC12'])
--cpu_flags('gcc', 'OPTIONS', 's390x', 'z13', ['-march=z13'])
--cpu_flags('gcc', 'OPTIONS', 's390x', 'z14', ['-march=z14'])
--cpu_flags('gcc', 'OPTIONS', 's390x', 'z15', ['-march=z15'])
- # AIX variant of RS/6000 & PowerPC
- flags('gcc', 'OPTIONS', ['<architecture>power/<address-model>32/<target-os>aix'], ['-maix32'])
- flags('gcc', 'OPTIONS', ['<architecture>power/<address-model>64/<target-os>aix'], ['-maix64'])
diff --git a/dev-util/boost-build/files/boost-build-1.77.0-darwin-gentoo-toolchain.patch b/dev-util/boost-build/files/boost-build-1.77.0-darwin-gentoo-toolchain.patch
deleted file mode 100644
index 2690e5fe5d97..000000000000
--- a/dev-util/boost-build/files/boost-build-1.77.0-darwin-gentoo-toolchain.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Avoid adding all kinds of things to the toolchain's flags that within
-Gentoo (Prefix) we really shouldn't, such as sysroot, deployment target,
-arch, etc.
-
---- a/tools/darwin.jam
-+++ b/tools/darwin.jam
-@@ -240,6 +240,9 @@
- }
- }
-
-+ # leave compiler flags etc. up to the toolchain
-+ return $(version-feature) ;
-+
- if $(version-feature)
- {
- if $(.debug-configuration)
-@@ -448,7 +451,8 @@
- support-ppc64 = ;
- }
- }
-- switch $(arch)
-+ # Gentoo Prefix toolchain doesn't do multi-arch, so don't try either
-+ switch $(donotaddarchpleaseXXXarch)
- {
- case combined :
- {