summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2024-04-10 11:58:57 +0200
committerAgostino Sarubbo <ago@gentoo.org>2024-04-10 11:58:57 +0200
commitcf22e6935a96198b61842027002d4ecdc57f59c0 (patch)
treeb8773bb4f1a12e24249e10beeb05679b8ffcdafa /dev-util/bugbite-cli
parentapp-text/pdfarranger: remove old revisions (diff)
downloadgentoo-cf22e6935a96198b61842027002d4ecdc57f59c0.tar.gz
gentoo-cf22e6935a96198b61842027002d4ecdc57f59c0.tar.bz2
gentoo-cf22e6935a96198b61842027002d4ecdc57f59c0.zip
dev-util/bugbite-cli: version bump to 0.0.8
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'dev-util/bugbite-cli')
-rw-r--r--dev-util/bugbite-cli/Manifest1
-rw-r--r--dev-util/bugbite-cli/bugbite-cli-0.0.8.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/bugbite-cli/Manifest b/dev-util/bugbite-cli/Manifest
index 21687a4d514a..3cd01f65d512 100644
--- a/dev-util/bugbite-cli/Manifest
+++ b/dev-util/bugbite-cli/Manifest
@@ -1 +1,2 @@
DIST bugbite-cli-0.0.7.tar.xz 28365584 BLAKE2B e1f38972e6ca43ae24761baf4c5c4675a171663c7347783134962d090bb12860fab84a3730bf894e86235f26f625a765c323fc659b90b729131d780bb6771856 SHA512 6330e1dd86ab1958681e14104da2e854fa3223c585fe14b913fb3777318a8b367579aa483c158a03fd89811ad4a28624d9629e8ea8682cffa5d2adb769a53d2f
+DIST bugbite-cli-0.0.8.tar.xz 25695676 BLAKE2B 9d9d1f65219d5e8e18e0cf785d3c8b22e5b02d71066cbd131c74d980b90d5479425ea9a4427eb63931c871a83a7f38c9e6de9fc3f6fa0404907b523895635232 SHA512 f708a1bb4604a75dbadca13a64db1952194db4b409ba1a5fc0e76ced5ebd00f3a97f563855f030c72b1296c10955260183c1eddee18c5bb76429edc1e8006a90
diff --git a/dev-util/bugbite-cli/bugbite-cli-0.0.8.ebuild b/dev-util/bugbite-cli/bugbite-cli-0.0.8.ebuild
new file mode 100644
index 000000000000..035c44ec12d5
--- /dev/null
+++ b/dev-util/bugbite-cli/bugbite-cli-0.0.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cargo edo shell-completion
+
+DESCRIPTION="A command line tool for bug, issue, and ticket mangling"
+HOMEPAGE="https://github.com/radhermit/bugbite"
+SRC_URI="https://github.com/radhermit/bugbite/releases/download/${P}/${P}.tar.xz"
+LICENSE="0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD BSD-2 Boost-1.0 CC0-1.0 ISC MIT MPL-2.0 Unicode-DFS-2016 Unlicense ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="static test"
+RESTRICT="!test? ( test ) "
+
+BDEPEND="
+ >=virtual/rust-1.75
+ test? ( dev-util/cargo-nextest )
+"
+
+QA_FLAGS_IGNORED="usr/bin/bite"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use static ; then
+ local rust_target=$( rustc -vV 2>/dev/null | sed -n 's|^host: ||p' )
+ [[ -z ${rust_target} ]] && die "Failed to read host target from rustc!"
+ export RUSTFLAGS="-C target-feature=+crt-static ${RUSTFLAGS}"
+ export static_stuff="--target ${rust_target}"
+ fi
+}
+
+src_configure() {
+ cargo_src_configure ${static_stuff}
+}
+
+src_test() {
+ edo cargo nextest run $(usev !debug '--release') --color always --all-features --tests ${static_stuff}
+}
+
+src_install() {
+ cargo_src_install
+
+ doman man/*
+ dofishcomp shell/bite.fish
+ dozshcomp shell/_bite
+ newbashcomp shell/bite.bash bite
+}