summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-10-26 19:13:04 -0700
committerBrian Dolbec <dolsen@gentoo.org>2017-10-26 19:28:20 -0700
commit5a6fe43f5fd95ae9dbc50cd12a4378ec43ff2690 (patch)
tree2334b74d3c8a277f1263288a76ee5a64904ea68d /dev-util/buildbot-console-view/buildbot-console-view-0.9.12.ebuild
parentdev-util/buildbot-worker: Version bump, clean old, eapi bump (diff)
downloadgentoo-5a6fe43f5fd95ae9dbc50cd12a4378ec43ff2690.tar.gz
gentoo-5a6fe43f5fd95ae9dbc50cd12a4378ec43ff2690.tar.bz2
gentoo-5a6fe43f5fd95ae9dbc50cd12a4378ec43ff2690.zip
dev-util/buildbot-console-view: Version bump, clean old, bump EAPI
Package-Manager: Portage-2.3.12, Repoman-2.3.4
Diffstat (limited to 'dev-util/buildbot-console-view/buildbot-console-view-0.9.12.ebuild')
-rw-r--r--dev-util/buildbot-console-view/buildbot-console-view-0.9.12.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/buildbot-console-view/buildbot-console-view-0.9.12.ebuild b/dev-util/buildbot-console-view/buildbot-console-view-0.9.12.ebuild
new file mode 100644
index 000000000000..0b002bd2400f
--- /dev/null
+++ b/dev-util/buildbot-console-view/buildbot-console-view-0.9.12.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 python3_5 )
+
+EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+DESCRIPTION="Buildbot console-view plugin"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.python.org/pypi/buildbot-console-view"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+
+IUSE="test"
+
+RDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+#[[ ${PV} == *9999 ]] && S=${S}/www/base
+
+python_test() {
+ distutils_install_for_testing
+
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}