summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2018-01-16 09:33:00 -0800
committerBrian Dolbec <dolsen@gentoo.org>2018-01-16 09:41:38 -0800
commit0a1d9e1d809f8e5eb22d7154cf0b60b44e6a30ab (patch)
tree628b18dc719e9f82f9a7c8517da8bbe150fc4b2d /dev-util/buildbot-console-view
parentdev-util/buildbot-pkg: Version bump (diff)
downloadgentoo-0a1d9e1d809f8e5eb22d7154cf0b60b44e6a30ab.tar.gz
gentoo-0a1d9e1d809f8e5eb22d7154cf0b60b44e6a30ab.tar.bz2
gentoo-0a1d9e1d809f8e5eb22d7154cf0b60b44e6a30ab.zip
dev-util/buildbot-console-view: Version bump
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-util/buildbot-console-view')
-rw-r--r--dev-util/buildbot-console-view/Manifest1
-rw-r--r--dev-util/buildbot-console-view/buildbot-console-view-0.9.15_p1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-util/buildbot-console-view/Manifest b/dev-util/buildbot-console-view/Manifest
index 970c00c6494e..6dde5f7c08a2 100644
--- a/dev-util/buildbot-console-view/Manifest
+++ b/dev-util/buildbot-console-view/Manifest
@@ -2,3 +2,4 @@ DIST buildbot-console-view-0.9.10.tar.gz 640908 BLAKE2B 04862718c7d635c98795b7b7
DIST buildbot-console-view-0.9.11.tar.gz 640623 BLAKE2B b364c99609696d4264faab85c22c885febaca1ced62123b5b917685bee6113065bc170b103bc1cd0f9333b3f3657dd8d30c1f73f5abb94f38664ee76bc593e97 SHA512 24a7915713665aeefe0389fa2aae1cdbde2b0dea0041b4a00410b77956b76897a9a427658303bf976916c5a0e3bb373a4a21339f4ded0b716d80ec380ad16cb4
DIST buildbot-console-view-0.9.12.tar.gz 640923 BLAKE2B cc0da84395aca571803e73260d826633553ed10ede6d66d112dfa8bcdc4f1bd376695ee0ee4a715f1fa3705329033044d9358731c0b807c54b40b4e32a04f565 SHA512 4a73994c29fe1f78c4432bdb42fe14106b8d7887bb35f2835b203f4818844d3e8d2ea308fc4fb2bd562de302bd7cf6612fe047476512feac068eca3891a49522
DIST buildbot-console-view-0.9.13.tar.gz 640969 BLAKE2B e0c6449c8208a34e568ed632be61fda0ae6ef0b183cd53e2288e1b89e03df6a874ec363f3cfdfa15005bc2913084eaf8640e86abf1ad2d19609e7b4c818f7b77 SHA512 16a3186a97112473fa1f7e811ceffe9f829d6181544e62290172b97b898ddb189fe8e67e223a3e02c936e61fc857a05e0b353dda7e5d4a3ce782f74a32515d2f
+DIST buildbot-console-view-0.9.15.post1.tar.gz 640548 BLAKE2B d28d3fbe40a8ceeaf574d2e8a9a6938664659dc6221a9e7e288c98b771cf7601a8db125dfb3cd71c500aee470a2b476a9daa0d5ec55a83758a96e97e14441def SHA512 42ad7d9dfdf0b3b0cda8d8dcd3fb2bd6734a775755fdc4ebe79d562f5ffb45d0e25d3ece15dec4a7542dd29e45a721e683bec416582901dbfa519c8da76cfa78
diff --git a/dev-util/buildbot-console-view/buildbot-console-view-0.9.15_p1.ebuild b/dev-util/buildbot-console-view/buildbot-console-view-0.9.15_p1.ebuild
new file mode 100644
index 000000000000..5f6501c2a710
--- /dev/null
+++ b/dev-util/buildbot-console-view/buildbot-console-view-0.9.15_p1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+DESCRIPTION="Buildbot console-view plugin"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.python.org/pypi/buildbot-console-view"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+
+IUSE="test"
+
+RDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+#[[ ${PV} == *9999 ]] && S=${S}/www/base
+
+python_test() {
+ distutils_install_for_testing
+
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}