summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2020-06-27 17:02:12 -0700
committerBrian Dolbec <dolsen@gentoo.org>2020-06-27 17:46:20 -0700
commitf22a7b5b0c0e8e238343e1e6b0f8d950e0c5dfa2 (patch)
treeb91cad78559d6dafb61881440e0d18abe80ad535 /dev-util/buildbot-pkg/buildbot-pkg-2.8.2.ebuild
parentdev-util/buildbot-worker: Version bump (diff)
downloadgentoo-f22a7b5b0c0e8e238343e1e6b0f8d950e0c5dfa2.tar.gz
gentoo-f22a7b5b0c0e8e238343e1e6b0f8d950e0c5dfa2.tar.bz2
gentoo-f22a7b5b0c0e8e238343e1e6b0f8d950e0c5dfa2.zip
dev-util/buildbot-pkg: Version bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-pkg/buildbot-pkg-2.8.2.ebuild')
-rw-r--r--dev-util/buildbot-pkg/buildbot-pkg-2.8.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/buildbot-pkg/buildbot-pkg-2.8.2.ebuild b/dev-util/buildbot-pkg/buildbot-pkg-2.8.2.ebuild
new file mode 100644
index 000000000000..24f94f8cc0d5
--- /dev/null
+++ b/dev-util/buildbot-pkg/buildbot-pkg-2.8.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="BuildBot common www build tools for packaging releases"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-pkg/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+# No real integration tests for this pkg.
+# all tests are related to making releases and final checks for distribution
+
+S=${WORKDIR}/${MY_P}