summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2024-01-28 17:54:46 +0100
committerSam James <sam@gentoo.org>2024-01-30 08:29:16 +0000
commit2f3dce2d68efcf278e4fef20d71ec7d7ad9f2636 (patch)
tree0df02aae092eaff24508d31adba065d47cd9faaf /dev-util/buildbot-react-console-view/buildbot-react-console-view-3.11.0.ebuild
parentdev-util/buildbot-pkg: add 3.11.0 (diff)
downloadgentoo-2f3dce2d68efcf278e4fef20d71ec7d7ad9f2636.tar.gz
gentoo-2f3dce2d68efcf278e4fef20d71ec7d7ad9f2636.tar.bz2
gentoo-2f3dce2d68efcf278e4fef20d71ec7d7ad9f2636.zip
dev-util/buildbot-react-console-view: add 3.11.0
Closes: https://bugs.gentoo.org/920676 Signed-off-by: Magnus Granberg <zorry@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-react-console-view/buildbot-react-console-view-3.11.0.ebuild')
-rw-r--r--dev-util/buildbot-react-console-view/buildbot-react-console-view-3.11.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/buildbot-react-console-view/buildbot-react-console-view-3.11.0.ebuild b/dev-util/buildbot-react-console-view/buildbot-react-console-view-3.11.0.ebuild
new file mode 100644
index 000000000000..7be81a8f30c4
--- /dev/null
+++ b/dev-util/buildbot-react-console-view/buildbot-react-console-view-3.11.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Buildbot react based console-view plugin"
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-react-console-view/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-react-${PV}[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"