summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2020-10-10 13:26:17 -0400
committerBrian Dolbec <dolsen@gentoo.org>2020-10-10 14:56:10 -0400
commit7b6cf597676efbd6f6f0f51540e9e02206c8b877 (patch)
tree653ef28547d911b109c6dcc210c2259baa9ede86 /dev-util/buildbot-waterfall-view/buildbot-waterfall-view-2.8.4.ebuild
parentdev-util/buildbot-www: Version bump to 2.8.4 (diff)
downloadgentoo-7b6cf597676efbd6f6f0f51540e9e02206c8b877.tar.gz
gentoo-7b6cf597676efbd6f6f0f51540e9e02206c8b877.tar.bz2
gentoo-7b6cf597676efbd6f6f0f51540e9e02206c8b877.zip
dev-util/buildbot-waterfall-view: Version bump to 2.8.4
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-waterfall-view/buildbot-waterfall-view-2.8.4.ebuild')
-rw-r--r--dev-util/buildbot-waterfall-view/buildbot-waterfall-view-2.8.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/buildbot-waterfall-view/buildbot-waterfall-view-2.8.4.ebuild b/dev-util/buildbot-waterfall-view/buildbot-waterfall-view-2.8.4.ebuild
new file mode 100644
index 000000000000..8e4b9cc0d871
--- /dev/null
+++ b/dev-util/buildbot-waterfall-view/buildbot-waterfall-view-2.8.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="Buildbot waterfall-view plugin"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-waterfall-view/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+ KEYWORDS="~amd64"
+
+IUSE=""
+
+RDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"