summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2021-01-17 12:40:32 -0500
committerBrian Dolbec <dolsen@gentoo.org>2021-01-17 13:45:30 -0500
commitc906d9a9797f14ab2cc0611cb6b149026046932d (patch)
tree2b207495b98261bbf57fc8fa15dfb8cf9a42251c /dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.10.0.ebuild
parentdev-util/buildbot-grid-view: Version bump to 2.10.0 fix setuptools ?depend (diff)
downloadgentoo-c906d9a9797f14ab2cc0611cb6b149026046932d.tar.gz
gentoo-c906d9a9797f14ab2cc0611cb6b149026046932d.tar.bz2
gentoo-c906d9a9797f14ab2cc0611cb6b149026046932d.zip
dev-util/buildbot-wsgi-dashboards: Version bump to 2.10.0 fix setuptools ?depend
Closes: https://bugs.gentoo.org/747739 Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.10.0.ebuild')
-rw-r--r--dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.10.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.10.0.ebuild b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.10.0.ebuild
new file mode 100644
index 000000000000..6a3f2fda7faa
--- /dev/null
+++ b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.10.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="Buildbot plugin to integrate flask or bottle dashboards to buildbot UI"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-wsgi-dashboards/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+RDEPEND=""
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"