summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2024-01-28 18:00:18 +0100
committerSam James <sam@gentoo.org>2024-01-30 08:29:18 +0000
commite4a9b33092cd5fc162d8dd742b798d182054ef77 (patch)
treeb537dd873d6e12b02f12fb75aeefac4164a1e764 /dev-util/buildbot-www-react/buildbot-www-react-3.11.0.ebuild
parentdev-util/buildbot-wsgi-dashboards: add 3.11.0 (diff)
downloadgentoo-e4a9b33092cd5fc162d8dd742b798d182054ef77.tar.gz
gentoo-e4a9b33092cd5fc162d8dd742b798d182054ef77.tar.bz2
gentoo-e4a9b33092cd5fc162d8dd742b798d182054ef77.zip
dev-util/buildbot-www-react: add 3.11.0
Closes: https://bugs.gentoo.org/920676 Signed-off-by: Magnus Granberg <zorry@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-www-react/buildbot-www-react-3.11.0.ebuild')
-rw-r--r--dev-util/buildbot-www-react/buildbot-www-react-3.11.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-util/buildbot-www-react/buildbot-www-react-3.11.0.ebuild b/dev-util/buildbot-www-react/buildbot-www-react-3.11.0.ebuild
new file mode 100644
index 000000000000..278991d26bc3
--- /dev/null
+++ b/dev-util/buildbot-www-react/buildbot-www-react-3.11.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="BuildBot base web interface, use with buildbot-react-{console-view,grid-view}..."
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-www-react/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~amd64-linux ~x86-linux"
+
+RDEPEND="~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"