summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-11-23 13:14:00 -0800
committerBrian Dolbec <dolsen@gentoo.org>2017-11-23 13:20:58 -0800
commitae88a676f2fb94fc38976cddc3167eedeb2ef787 (patch)
tree9b4a9ba77077a5a625f0502f1534e2ab6ab7ea2a /dev-util/buildbot-www/buildbot-www-0.9.13.ebuild
parentdev-util/buildbot-worker: Version bump, adds python3_{4,6} (diff)
downloadgentoo-ae88a676f2fb94fc38976cddc3167eedeb2ef787.tar.gz
gentoo-ae88a676f2fb94fc38976cddc3167eedeb2ef787.tar.bz2
gentoo-ae88a676f2fb94fc38976cddc3167eedeb2ef787.zip
dev-util/buildbot-www: Version bump, adds python3_{4,6}
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-util/buildbot-www/buildbot-www-0.9.13.ebuild')
-rw-r--r--dev-util/buildbot-www/buildbot-www-0.9.13.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/buildbot-www/buildbot-www-0.9.13.ebuild b/dev-util/buildbot-www/buildbot-www-0.9.13.ebuild
new file mode 100644
index 000000000000..255bdb148ef5
--- /dev/null
+++ b/dev-util/buildbot-www/buildbot-www-0.9.13.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+DESCRIPTION="BuildBot base web interface, use with buildbot-{console-view,waterfall-view}..."
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.python.org/pypi/buildbot-www"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+
+IUSE="test"
+
+RDEPEND=""
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+#[[ ${PV} == *9999 ]] && S=${S}/www/base
+
+python_test() {
+ distutils_install_for_testing
+
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}