summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec dolsen <dolsen@gentoo.org>2018-07-26 09:59:06 -0700
committerBrian Dolbec dolsen <dolsen@gentoo.org>2018-07-26 10:17:09 -0700
commit5963fb474e70a9386e8dcf9a9a26c1a93a89917f (patch)
tree9fb7fce221d74f561130cd5cf0189cb836b21d33 /dev-util/buildbot-www/buildbot-www-1.3.0.ebuild
parentdev-util/buildbot-pkg: Version bump to 1.3.0 (diff)
downloadgentoo-5963fb474e70a9386e8dcf9a9a26c1a93a89917f.tar.gz
gentoo-5963fb474e70a9386e8dcf9a9a26c1a93a89917f.tar.bz2
gentoo-5963fb474e70a9386e8dcf9a9a26c1a93a89917f.zip
dev-util/buildbot-www: Version bump to 1.3.0
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-util/buildbot-www/buildbot-www-1.3.0.ebuild')
-rw-r--r--dev-util/buildbot-www/buildbot-www-1.3.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/buildbot-www/buildbot-www-1.3.0.ebuild b/dev-util/buildbot-www/buildbot-www-1.3.0.ebuild
new file mode 100644
index 000000000000..8ee469d1634d
--- /dev/null
+++ b/dev-util/buildbot-www/buildbot-www-1.3.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+DESCRIPTION="BuildBot base web interface, use with buildbot-{console-view,waterfall-view}..."
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-www/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+
+IUSE="test"
+
+RDEPEND=""
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+#[[ ${PV} == *9999 ]] && S=${S}/www/base
+
+python_test() {
+ distutils_install_for_testing
+
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}