summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2021-01-17 12:30:35 -0500
committerBrian Dolbec <dolsen@gentoo.org>2021-01-17 13:45:29 -0500
commit8a97449a971f94607e259e3cea279f20473d1491 (patch)
tree1143db209184d0153b4ac0d03f151d8b12f03730 /dev-util/buildbot-www/buildbot-www-2.10.0.ebuild
parentdev-util/buildbot-worker: Bump to 2.10.0 (diff)
downloadgentoo-8a97449a971f94607e259e3cea279f20473d1491.tar.gz
gentoo-8a97449a971f94607e259e3cea279f20473d1491.tar.bz2
gentoo-8a97449a971f94607e259e3cea279f20473d1491.zip
dev-util/buildbot-www: Version bump to 2.10.0 fix setuptools ?depend
Closes: https://bugs.gentoo.org/747730 Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-www/buildbot-www-2.10.0.ebuild')
-rw-r--r--dev-util/buildbot-www/buildbot-www-2.10.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/buildbot-www/buildbot-www-2.10.0.ebuild b/dev-util/buildbot-www/buildbot-www-2.10.0.ebuild
new file mode 100644
index 000000000000..d81233cd01ad
--- /dev/null
+++ b/dev-util/buildbot-www/buildbot-www-2.10.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="BuildBot base web interface, use with buildbot-{console-view,waterfall-view}..."
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-www/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+DEPEND="
+ ~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"