summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2020-06-27 17:02:34 -0700
committerBrian Dolbec <dolsen@gentoo.org>2020-06-27 17:46:20 -0700
commit374723cadd2cbb72017de55a02f2b0cdb7af66c5 (patch)
treefbba45221ea13110c64f64641ab8b3fe3aacb4ca /dev-util/buildbot-www/buildbot-www-2.8.2.ebuild
parentdev-util/buildbot-pkg: Version bump (diff)
downloadgentoo-374723cadd2cbb72017de55a02f2b0cdb7af66c5.tar.gz
gentoo-374723cadd2cbb72017de55a02f2b0cdb7af66c5.tar.bz2
gentoo-374723cadd2cbb72017de55a02f2b0cdb7af66c5.zip
dev-util/buildbot-www: Version bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-www/buildbot-www-2.8.2.ebuild')
-rw-r--r--dev-util/buildbot-www/buildbot-www-2.8.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/buildbot-www/buildbot-www-2.8.2.ebuild b/dev-util/buildbot-www/buildbot-www-2.8.2.ebuild
new file mode 100644
index 000000000000..c5f7aebcb28c
--- /dev/null
+++ b/dev-util/buildbot-www/buildbot-www-2.8.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="BuildBot base web interface, use with buildbot-{console-view,waterfall-view}..."
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-www/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+DEPEND="
+ ~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"