summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2021-03-28 18:04:23 -0400
committerBrian Dolbec <dolsen@gentoo.org>2021-03-28 18:16:04 -0400
commit62eb7426497f882da2063d49fdf7c7d954582330 (patch)
tree4148a9858d3b5c648f6cda898f783517bd208d1e /dev-util/buildbot-www/buildbot-www-3.0.2.ebuild
parentdev-util/buildbot-pkg: Version bump to 3.0.2, adds py3.9 (diff)
downloadgentoo-62eb7426497f882da2063d49fdf7c7d954582330.tar.gz
gentoo-62eb7426497f882da2063d49fdf7c7d954582330.tar.bz2
gentoo-62eb7426497f882da2063d49fdf7c7d954582330.zip
dev-util/buildbot-www: Version bump to 3.0.2, adds py3.9
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-www/buildbot-www-3.0.2.ebuild')
-rw-r--r--dev-util/buildbot-www/buildbot-www-3.0.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/buildbot-www/buildbot-www-3.0.2.ebuild b/dev-util/buildbot-www/buildbot-www-3.0.2.ebuild
new file mode 100644
index 000000000000..70027ef7887a
--- /dev/null
+++ b/dev-util/buildbot-www/buildbot-www-3.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="BuildBot base web interface, use with buildbot-{console-view,waterfall-view}..."
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-www/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+DEPEND="
+ ~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"