summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2018-01-15 17:05:11 -0800
committerBrian Dolbec <dolsen@gentoo.org>2018-01-16 09:41:38 -0800
commit49514530a8d66c0078302b3363bf2d9f825bbcb6 (patch)
tree7aee9996e75fd7c6097a8320b47744bfc8333791 /dev-util/buildbot/buildbot-9999.ebuild
parentvirtualbox packages: Removed old. (diff)
downloadgentoo-49514530a8d66c0078302b3363bf2d9f825bbcb6.tar.gz
gentoo-49514530a8d66c0078302b3363bf2d9f825bbcb6.tar.bz2
gentoo-49514530a8d66c0078302b3363bf2d9f825bbcb6.zip
dev-util/buildbot: Version bump, update 9999 ebuild
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-util/buildbot/buildbot-9999.ebuild')
-rw-r--r--dev-util/buildbot/buildbot-9999.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-util/buildbot/buildbot-9999.ebuild b/dev-util/buildbot/buildbot-9999.ebuild
index a9a9d7adf5f6..4d20f12a6a23 100644
--- a/dev-util/buildbot/buildbot-9999.ebuild
+++ b/dev-util/buildbot/buildbot-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -10,7 +10,7 @@ EGIT_REPO_URI="https://github.com/buildbot/${PN}.git"
[[ ${PV} == *9999 ]] && inherit git-r3
inherit readme.gentoo-r1 user systemd distutils-r1
-MY_PV="${PV/_p/p}"
+MY_PV="${PV/_p/.post}"
MY_P="${PN}-${MY_PV}"
DESCRIPTION="BuildBot build automation system"
@@ -25,7 +25,7 @@ else
KEYWORDS="~amd64"
fi
-IUSE="crypt doc examples irc test"
+IUSE="crypt doc docker examples irc test"
RDEPEND="
>=dev-python/jinja-2.1[${PYTHON_USEDEP}]
@@ -48,6 +48,9 @@ RDEPEND="
irc? (
dev-python/txrequests[${PYTHON_USEDEP}]
)
+ docker? (
+ >=dev-python/docker-py-2.2.0[${PYTHON_USEDEP}]
+ )
"
DEPEND="${RDEPEND}
>=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
@@ -74,6 +77,7 @@ DEPEND="${RDEPEND}
dev-python/treq[${PYTHON_USEDEP}]
dev-python/setuptools_trial[${PYTHON_USEDEP}]
~dev-util/buildbot-worker-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.2.0[${PYTHON_USEDEP}]
)"
S=${WORKDIR}/${MY_P}