summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-10-26 18:50:33 -0700
committerBrian Dolbec <dolsen@gentoo.org>2017-10-26 19:28:19 -0700
commit6728c73b7a88f1cc229ae0715a72671178d17e8d (patch)
treedf77ef372ee6fd7f8cb5ef0b19e63593a67f3e86 /dev-util/buildbot/buildbot-9999.ebuild
parentdev-python/twisted: Version bump. Addtional test fixes... (diff)
downloadgentoo-6728c73b7a88f1cc229ae0715a72671178d17e8d.tar.gz
gentoo-6728c73b7a88f1cc229ae0715a72671178d17e8d.tar.bz2
gentoo-6728c73b7a88f1cc229ae0715a72671178d17e8d.zip
dev-util/buildbot: Version bump, remove old versions, fix bug 634716
Remove no longer shipped docker example. Remove old versions. Update 9999 deps Bump eapi. Package-Manager: Portage-2.3.12, Repoman-2.3.4
Diffstat (limited to 'dev-util/buildbot/buildbot-9999.ebuild')
-rw-r--r--dev-util/buildbot/buildbot-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-util/buildbot/buildbot-9999.ebuild b/dev-util/buildbot/buildbot-9999.ebuild
index 694b31c8f116..0b08a8046964 100644
--- a/dev-util/buildbot/buildbot-9999.ebuild
+++ b/dev-util/buildbot/buildbot-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
PYTHON_REQ_USE="sqlite"
PYTHON_COMPAT=( python2_7 python3_5 )
@@ -29,7 +29,7 @@ IUSE="crypt doc examples irc test"
RDEPEND="
>=dev-python/jinja-2.1[${PYTHON_USEDEP}]
- >=dev-python/twisted-17.5.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-17.9.0[${PYTHON_USEDEP}]
>=dev-python/autobahn-0.16.0[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-0.8[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-migrate-0.9[${PYTHON_USEDEP}]
@@ -40,7 +40,7 @@ RDEPEND="
>=dev-python/zope-interface-4.1.1[${PYTHON_USEDEP}]
~dev-util/buildbot-worker-${PV}[${PYTHON_USEDEP}]
crypt? (
- >=dev-python/twisted-17.5.0[${PYTHON_USEDEP},crypt]
+ >=dev-python/twisted-17.9.0[${PYTHON_USEDEP},crypt]
>=dev-python/pyopenssl-16.0.0[${PYTHON_USEDEP}]
dev-python/idna[${PYTHON_USEDEP}]
dev-python/service_identity[${PYTHON_USEDEP}]
@@ -112,7 +112,7 @@ src_install() {
if use examples; then
insinto /usr/share/doc/${PF}
- doins -r docker docs/examples
+ doins -r docs/examples
fi
newconfd "${FILESDIR}/buildmaster.confd" buildmaster