summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2016-08-09 15:46:55 -0700
committerBrian Dolbec <dolsen@gentoo.org>2016-08-09 16:47:21 -0700
commit6876c4d431ee294c53d563d6542f582da9722900 (patch)
treea73ef4dbbf01429b2cb10b71310dcd92a5e5b3af /dev-util/buildbot/buildbot-9999.ebuild
parentdev-python/future: Add ~x86 keyword (diff)
downloadgentoo-6876c4d431ee294c53d563d6542f582da9722900.tar.gz
gentoo-6876c4d431ee294c53d563d6542f582da9722900.tar.bz2
gentoo-6876c4d431ee294c53d563d6542f582da9722900.zip
dev-util/buildbot: Version bump, update live ebuild
This version is a major change from previous version.
Diffstat (limited to 'dev-util/buildbot/buildbot-9999.ebuild')
-rw-r--r--dev-util/buildbot/buildbot-9999.ebuild145
1 files changed, 99 insertions, 46 deletions
diff --git a/dev-util/buildbot/buildbot-9999.ebuild b/dev-util/buildbot/buildbot-9999.ebuild
index dbde043b37ec..8a0d136f19c9 100644
--- a/dev-util/buildbot/buildbot-9999.ebuild
+++ b/dev-util/buildbot/buildbot-9999.ebuild
@@ -1,52 +1,97 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
-PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 )
EGIT_REPO_URI="https://github.com/buildbot/${PN}.git"
-[[ ${PV} = 9999 ]] && inherit git-2
-inherit distutils-r1 readme.gentoo systemd user
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit readme.gentoo-r1 user systemd distutils-r1
MY_PV="${PV/_p/p}"
MY_P="${PN}-${MY_PV}"
DESCRIPTION="BuildBot build automation system"
-HOMEPAGE="http://buildbot.net/ https://pypi.python.org/pypi/buildbot"
-[[ ${PV} = 9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://trac.buildbot.net/ https://github.com/buildbot/buildbot http://pypi.python.org/pypi/buildbot"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-if [[ ${PV} == 9999 ]]; then
+if [[ ${PV} == *9999 ]]; then
KEYWORDS=""
else
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+ KEYWORDS="~amd64"
fi
-IUSE="doc examples irc mail manhole test"
+
+IUSE="crypt doc examples irc mail manhole test"
RDEPEND=">=dev-python/jinja-2.1[${PYTHON_USEDEP}]
- dev-python/twisted-core[${PYTHON_USEDEP}]
- dev-python/twisted-web[${PYTHON_USEDEP}]
- <=dev-python/sqlalchemy-0.7.10-r999[${PYTHON_USEDEP}]
- ~dev-python/sqlalchemy-migrate-0.7.2[${PYTHON_USEDEP}]
- irc? ( dev-python/twisted-words[${PYTHON_USEDEP}] )
- mail? ( dev-python/twisted-mail[${PYTHON_USEDEP}] )
- manhole? ( dev-python/twisted-conch[${PYTHON_USEDEP}] )"
-DEPEND="${DEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ || (
+ >=dev-python/twisted-web-14.0.1[${PYTHON_USEDEP}]
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+ )
+ >=dev-python/sqlalchemy-0.8[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-migrate-0.9[${PYTHON_USEDEP}]
+ crypt? (
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/service_identity[${PYTHON_USEDEP}]
+ )
+ irc? (
+ || ( >=dev-python/twisted-words-14.0.1[${PYTHON_USEDEP}]
+ <dev-python/twisted-16.3.0[${PYTHON_USEDEP}]
+ )
+ )
+ mail? (
+ || ( >=dev-python/twisted-mail-14.0.1[${PYTHON_USEDEP}]
+ <dev-python/twisted-16.3.0[${PYTHON_USEDEP}]
+ )
+ )
+ manhole? (
+ || ( >=dev-python/twisted-conch-14.0.1[${PYTHON_USEDEP}]
+ <dev-python/twisted-16.3.0[${PYTHON_USEDEP}]
+ )
+ )
+ dev-python/future[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
+ >=dev-python/autobahn-0.10.2[${PYTHON_USEDEP}]
+ <dev-python/autobahn-0.13.0[${PYTHON_USEDEP}]
+ >=dev-python/txaio-2.2.2[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+ doc? ( >=dev-python/sphinx-1.4.3[${PYTHON_USEDEP}] )
test? (
- dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
- dev-python/twisted-mail[${PYTHON_USEDEP}]
- dev-python/twisted-web[${PYTHON_USEDEP}]
- dev-python/twisted-words[${PYTHON_USEDEP}]
+ || (
+ (
+ >=dev-python/twisted-mail-14.0.1[${PYTHON_USEDEP}]
+ >=dev-python/twisted-web-14.0.1[${PYTHON_USEDEP}]
+ >=dev-python/twisted-words-14.0.1[${PYTHON_USEDEP}]
+ )
+ <dev-python/twisted-16.3.0[${PYTHON_USEDEP}]
+ )
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/ramlfications[${PYTHON_USEDEP}]
+ dev-python/pyjade[${PYTHON_USEDEP}]
+ dev-python/txgithub[${PYTHON_USEDEP}]
+ dev-python/txrequests[${PYTHON_USEDEP}]
)"
-S="${WORKDIR}/${MY_P}"
+# still yet to be added deps
+# doc? ( 'sphinxcontrib-blockdiag',
+# 'sphinxcontrib-spelling',
+# 'pyenchant',
+# 'docutils>=0.8',
+# 'sphinx-jinja',)
+
+S=${WORKDIR}/${MY_P}
+[[ ${PV} == *9999 ]] && S=${S}/master
pkg_setup() {
enewuser buildbot
@@ -60,38 +105,46 @@ pkg_setup() {
build master, just copy the scripts."
}
-src_compile() {
- [[ ${PV} = 9999 ]] && cd master/
- distutils-r1_src_compile
+# docs generation is broken might need a separate ebuild
+#python_compile_all() {
+ #if use doc; then
+ #einfo "Generation of documentation"
+ ##'man' target is currently broken
+ #emake -C docs html
+ #fi
+#}
- if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- #'man' target is currently broken
- emake html
- popd > /dev/null
- fi
-}
-
-src_install() {
- [[ ${PV} = 9999 ]] && cd master/
- distutils-r1_src_install
+python_install_all() {
+ distutils-r1_python_install_all
doman docs/buildbot.1
- if use doc; then
- dohtml -r docs/_build/html/
- # TODO: install man pages
- fi
+ #if use doc; then
+ # dohtml -r docs/_build/html/
+ # # TODO: install man pages
+ #fi
if use examples; then
insinto /usr/share/doc/${PF}
doins -r contrib docs/examples
fi
- newconfd "${FILESDIR}/buildmaster.confd" buildmaster
- newinitd "${FILESDIR}/buildmaster.initd" buildmaster
- systemd_dounit "${FILESDIR}"/${PN}.service
+ newconfd "${FILESDIR}"/buildmaster.confd.9 buildmaster
+ newinitd "${FILESDIR}"/buildmaster.initd.9 buildmaster
+ systemd_dounit "${FILESDIR}/${PN}9".service
+
+ # In case of multiple masters, it's possible to edit web files
+ # so all master can share the changes. So protect them!
+ # If something else need to be protected, please open a bug
+ # on http://bugs.gentoo.org
+ local cp
+ add_config_protect() {
+ cp+=" $(python_get_sitedir)/${PN}/status/web"
+ }
+ python_foreach_impl add_config_protect
+ echo "CONFIG_PROTECT=\"${cp}\"" \
+ > 85${PN} || die
+ doenvd 85${PN}
readme.gentoo_create_doc
}