summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2016-10-12 14:58:49 -0700
committerBrian Dolbec <dolsen@gentoo.org>2016-10-12 15:07:34 -0700
commitea7c2fa057f5f61a497e3bf60838ee72384b026b (patch)
treefa86d1cef1971c6115fdbee213193d79b3d07d6a /dev-util/buildbot/buildbot-9999.ebuild
parentnet-firewall/shorewall: Bump to v5.0.12.1 (diff)
downloadgentoo-ea7c2fa057f5f61a497e3bf60838ee72384b026b.tar.gz
gentoo-ea7c2fa057f5f61a497e3bf60838ee72384b026b.tar.bz2
gentoo-ea7c2fa057f5f61a497e3bf60838ee72384b026b.zip
dev-util/buildbot: Update the twisted dep order to prefer the new twisted pkg
With the new twisted pkg now in the tree, prefer the new pkg. There will be no new releases of the split pkgs. Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-util/buildbot/buildbot-9999.ebuild')
-rw-r--r--dev-util/buildbot/buildbot-9999.ebuild27
1 files changed, 9 insertions, 18 deletions
diff --git a/dev-util/buildbot/buildbot-9999.ebuild b/dev-util/buildbot/buildbot-9999.ebuild
index 1d53a34a8a5f..9bf2d9d13b69 100644
--- a/dev-util/buildbot/buildbot-9999.ebuild
+++ b/dev-util/buildbot/buildbot-9999.ebuild
@@ -30,9 +30,10 @@ IUSE="crypt doc examples irc mail manhole test"
RDEPEND=">=dev-python/jinja-2.1[${PYTHON_USEDEP}]
|| (
- >=dev-python/twisted-web-14.0.1[${PYTHON_USEDEP}]
>=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-web-14.0.1[${PYTHON_USEDEP}]
)
+ >=dev-python/autobahn-0.16.0[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-0.8[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-migrate-0.9[${PYTHON_USEDEP}]
crypt? (
@@ -42,32 +43,22 @@ RDEPEND=">=dev-python/jinja-2.1[${PYTHON_USEDEP}]
)
irc? (
dev-python/txrequests[${PYTHON_USEDEP}]
- || ( >=dev-python/twisted-words-14.0.1[${PYTHON_USEDEP}]
- >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+ || ( >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-words-14.0.1[${PYTHON_USEDEP}]
)
)
mail? (
- || ( >=dev-python/twisted-mail-14.0.1[${PYTHON_USEDEP}]
- >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+ || ( >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-mail-14.0.1[${PYTHON_USEDEP}]
)
)
manhole? (
- || ( >=dev-python/twisted-conch-14.0.1[${PYTHON_USEDEP}]
- >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+ || ( >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-conch-14.0.1[${PYTHON_USEDEP}]
)
)
dev-python/future[${PYTHON_USEDEP}]
>=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
- || (
- ( !<dev-python/twisted-16.3.0[${PYTHON_USEDEP}]
- >=dev-python/autobahn-0.16.0[${PYTHON_USEDEP}]
- )
- ( || ( <dev-python/twisted-16.3.0[${PYTHON_USEDEP}]
- dev-python/twisted-core[${PYTHON_USEDEP}]
- )
- dev-python/autobahn[${PYTHON_USEDEP}]
- )
- )
>=dev-python/txaio-2.2.2[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
@@ -77,12 +68,12 @@ DEPEND="${RDEPEND}
>=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
|| (
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
(
>=dev-python/twisted-mail-14.0.1[${PYTHON_USEDEP}]
>=dev-python/twisted-web-14.0.1[${PYTHON_USEDEP}]
>=dev-python/twisted-words-14.0.1[${PYTHON_USEDEP}]
)
- >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
)
dev-python/moto[${PYTHON_USEDEP}]
dev-python/boto3[${PYTHON_USEDEP}]