summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-02-10 13:19:22 -0800
committerBrian Dolbec <dolsen@gentoo.org>2017-02-10 13:49:20 -0800
commitc55e4f15deb6f77dca0240284dd491441e27e9c3 (patch)
tree2474f2c5d129141fdfb0b000cf2a8e115449b538 /dev-util/buildbot/files
parentdev-python/sphinx-jinja: New package, dep of buildot[doc] (diff)
downloadgentoo-c55e4f15deb6f77dca0240284dd491441e27e9c3.tar.gz
gentoo-c55e4f15deb6f77dca0240284dd491441e27e9c3.tar.bz2
gentoo-c55e4f15deb6f77dca0240284dd491441e27e9c3.zip
dev-util/buildbot: Version bump, enable docs use flag
I now have sphinx docs generation working for this ebuild. Patches submitted upstream for missing files. Package-Manager: Portage-2.3.3_p38, Repoman-2.3.1_p31 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util/buildbot/files')
-rw-r--r--dev-util/buildbot/files/buildbot-0.9.4.docs.patch130
1 files changed, 130 insertions, 0 deletions
diff --git a/dev-util/buildbot/files/buildbot-0.9.4.docs.patch b/dev-util/buildbot/files/buildbot-0.9.4.docs.patch
new file mode 100644
index 000000000000..1a27713cb939
--- /dev/null
+++ b/dev-util/buildbot/files/buildbot-0.9.4.docs.patch
@@ -0,0 +1,130 @@
+diff --git a/docs/Makefile b/docs/Makefile
+index 55637302d..c4fde481e 100644
+--- a/docs/Makefile
++++ b/docs/Makefile
+@@ -24,7 +24,7 @@ PAPEROPT_a4 = -D latex_paper_size=a4
+ PAPEROPT_letter = -D latex_paper_size=letter
+ ALLSPHINXOPTS = -d $(BUILDDIR)/doctrees $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
+
+-.PHONY: help clean towncrier html dirhtml singlehtml pickle json htmlhelp qthelp devhelp epub latex latexpdf text man changes linkcheck doctest
++.PHONY: help clean html dirhtml singlehtml pickle json htmlhelp qthelp devhelp epub latex latexpdf text man changes linkcheck doctest
+
+ help:
+ @echo "Please use \`make <target>' where <target> is one of"
+@@ -51,38 +51,38 @@ clean:
+ towncrier:
+ cd ../../; towncrier --draft |grep 'No significant changes.' || yes n | towncrier
+
+-html: conf.py towncrier
++html: conf.py
+ $(SPHINXBUILD) -b html $(ALLSPHINXOPTS) $(BUILDDIR)/html
+ @echo
+ @echo "Build finished. The HTML pages are in $(BUILDDIR)/html."
+
+-dirhtml: conf.py towncrier
++dirhtml: conf.py
+ $(SPHINXBUILD) -b dirhtml $(ALLSPHINXOPTS) $(BUILDDIR)/dirhtml
+ @echo
+ @echo "Build finished. The HTML pages are in $(BUILDDIR)/dirhtml."
+
+-singlehtml: conf.py towncrier
++singlehtml: conf.py
+ $(SPHINXBUILD) -b singlehtml $(ALLSPHINXOPTS) $(BUILDDIR)/singlehtml
+ @echo
+ @echo "Build finished. The HTML page is in $(BUILDDIR)/singlehtml."
+
+-pickle: conf.py towncrier
++pickle: conf.py
+ $(SPHINXBUILD) -b pickle $(ALLSPHINXOPTS) $(BUILDDIR)/pickle
+ @echo
+ @echo "Build finished; now you can process the pickle files."
+
+-json: conf.py towncrier
++json: conf.py
+ $(SPHINXBUILD) -b json $(ALLSPHINXOPTS) $(BUILDDIR)/json
+ @echo
+ @echo "Build finished; now you can process the JSON files."
+
+-htmlhelp: conf.py towncrier
++htmlhelp: conf.py
+ $(SPHINXBUILD) -b htmlhelp $(ALLSPHINXOPTS) $(BUILDDIR)/htmlhelp
+ @echo
+ @echo "Build finished; now you can run HTML Help Workshop with the" \
+ ".hhp project file in $(BUILDDIR)/htmlhelp."
+
+-qthelp: conf.py towncrier
++qthelp: conf.py
+ $(SPHINXBUILD) -b qthelp $(ALLSPHINXOPTS) $(BUILDDIR)/qthelp
+ @echo
+ @echo "Build finished; now you can run "qcollectiongenerator" with the" \
+@@ -91,7 +91,7 @@ qthelp: conf.py towncrier
+ @echo "To view the help file:"
+ @echo "# assistant -collectionFile $(BUILDDIR)/qthelp/BuildbotTutorial.qhc"
+
+-devhelp: conf.py towncrier
++devhelp: conf.py
+ $(SPHINXBUILD) -b devhelp $(ALLSPHINXOPTS) $(BUILDDIR)/devhelp
+ @echo
+ @echo "Build finished."
+@@ -100,52 +100,52 @@ devhelp: conf.py towncrier
+ @echo "# ln -s $(BUILDDIR)/devhelp $$HOME/.local/share/devhelp/BuildbotTutorial"
+ @echo "# devhelp"
+
+-epub: conf.py towncrier
++epub: conf.py
+ $(SPHINXBUILD) -b epub $(ALLSPHINXOPTS) $(BUILDDIR)/epub
+ @echo
+ @echo "Build finished. The epub file is in $(BUILDDIR)/epub."
+
+-latex: conf.py towncrier
++latex: conf.py
+ $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
+ @echo
+ @echo "Build finished; the LaTeX files are in $(BUILDDIR)/latex."
+ @echo "Run \`make' in that directory to run these through (pdf)latex" \
+ "(use \`make latexpdf' here to do that automatically)."
+
+-latexpdf: conf.py towncrier
++latexpdf: conf.py
+ $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
+ @echo "Running LaTeX files through pdflatex..."
+ make -C $(BUILDDIR)/latex all-pdf
+ @echo "pdflatex finished; the PDF files are in $(BUILDDIR)/latex."
+
+-text: conf.py towncrier
++text: conf.py
+ $(SPHINXBUILD) -b text $(ALLSPHINXOPTS) $(BUILDDIR)/text
+ @echo
+ @echo "Build finished. The text files are in $(BUILDDIR)/text."
+
+-man: conf.py towncrier
++man: conf.py
+ $(SPHINXBUILD) -b man $(ALLSPHINXOPTS) $(BUILDDIR)/man
+ @echo
+ @echo "Build finished. The manual pages are in $(BUILDDIR)/man."
+
+-changes: conf.py towncrier
++changes: conf.py
+ $(SPHINXBUILD) -b changes $(ALLSPHINXOPTS) $(BUILDDIR)/changes
+ @echo
+ @echo "The overview file is in $(BUILDDIR)/changes."
+
+-linkcheck: conf.py towncrier
++linkcheck: conf.py
+ $(SPHINXBUILD) -b linkcheck $(ALLSPHINXOPTS) $(BUILDDIR)/linkcheck
+ @echo
+ @echo "Link check complete; look for any errors in the above output " \
+ "or in $(BUILDDIR)/linkcheck/output.txt."
+
+-spelling: conf.py towncrier
++spelling: conf.py
+ $(SPHINXBUILD) -b spelling $(ALLSPHINXOPTS) $(BUILDDIR)/spelling
+ @echo
+ @echo "Spelling check complete; look for any errors in the above output " \
+ "or in $(BUILDDIR)/spelling/output.txt."
+
+-doctest: conf.py towncrier
++doctest: conf.py
+ $(SPHINXBUILD) -b doctest $(ALLSPHINXOPTS) $(BUILDDIR)/doctest
+ @echo "Testing of doctests in the sources finished, look at the " \
+ "results in $(BUILDDIR)/doctest/output.txt."