summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-31 23:40:44 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-31 23:40:44 +0200
commit00d6eb085b6496f532e7ce95959371d30825e86c (patch)
tree5c6eddb5837d19eae0e07146229a11d57f94b9c9 /dev-util/catfish
parentdev-perl/PPI: EAPI=8 bump (diff)
downloadgentoo-00d6eb085b6496f532e7ce95959371d30825e86c.tar.gz
gentoo-00d6eb085b6496f532e7ce95959371d30825e86c.tar.bz2
gentoo-00d6eb085b6496f532e7ce95959371d30825e86c.zip
dev-util/catfish: Bump to 4.16.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/catfish')
-rw-r--r--dev-util/catfish/Manifest1
-rw-r--r--dev-util/catfish/catfish-4.16.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/catfish/Manifest b/dev-util/catfish/Manifest
index 17bb3afae0d4..65ec18760565 100644
--- a/dev-util/catfish/Manifest
+++ b/dev-util/catfish/Manifest
@@ -1 +1,2 @@
DIST catfish-4.16.0.tar.bz2 261252 BLAKE2B b495814857cb551c00dff8b92d2b24df876b1ab269bcb0ba468c791b97f3e962b875c5a687010472c5d47719475c99131d5ee6df3ce642af147b199976eb3538 SHA512 926318d3b2387386a5141347cf23b7e1505f83c48dac3804dc9c51aeeede2ef71d6d70e61bd5f608145249ccb4d3d87662bdab0c0a88dc69608b2edee55ddc19
+DIST catfish-4.16.2.tar.bz2 270051 BLAKE2B 41048edc3933664af389ae7120e6f2b25f6c92632a4d00b999eef4e26e0f6eeeed70320ed740f26a0649e423e3b8316e33b8c671a282ae1a4474b3cc6bbc4824 SHA512 a1dc2839106d55e11e537478402b44d3794cdcf326c5984bd95d0d5a8bad52d91df1be22ba347d23f030d0c62fdf2b90a507e2abc30ed4b4d1804ab8dbde1dbe
diff --git a/dev-util/catfish/catfish-4.16.2.ebuild b/dev-util/catfish/catfish-4.16.2.ebuild
new file mode 100644
index 000000000000..e20eafa63bda
--- /dev/null
+++ b/dev-util/catfish/catfish-4.16.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A frontend for find, (s)locate, doodle, tracker, beagle, strigi and pinot"
+HOMEPAGE="https://docs.xfce.org/apps/catfish/start"
+SRC_URI="https://archive.xfce.org/src/apps/catfish/${PV%.*}/${P}.tar.bz2"
+
+# yep, GPL-2 only
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.42
+ dev-libs/gobject-introspection
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf[introspection]
+ >=x11-libs/gtk+-3.22:3[introspection]
+ x11-libs/pango[introspection]
+ >=xfce-base/xfconf-4.14[introspection]
+ virtual/freedesktop-icon-theme
+"
+BDEPEND="
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ sys-devel/gettext
+"
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+ rm -r "${ED}"/usr/share/doc/catfish || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}