summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-07-17 09:04:18 +0200
committerMichał Górny <mgorny@gentoo.org>2018-07-17 09:24:19 +0200
commit8228afae34028b31cfbf87382f916a48c98d2294 (patch)
tree560d78ec6b6512674863c56296451c103a036d4e /dev-util/catfish
parentdev-util/catfish: now an xfce project! (diff)
downloadgentoo-8228afae34028b31cfbf87382f916a48c98d2294.tar.gz
gentoo-8228afae34028b31cfbf87382f916a48c98d2294.tar.bz2
gentoo-8228afae34028b31cfbf87382f916a48c98d2294.zip
dev-util/catfish: Bump to 1.4.6
Diffstat (limited to 'dev-util/catfish')
-rw-r--r--dev-util/catfish/Manifest1
-rw-r--r--dev-util/catfish/catfish-1.4.6.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/catfish/Manifest b/dev-util/catfish/Manifest
index b4544883a655..7da3eea211cb 100644
--- a/dev-util/catfish/Manifest
+++ b/dev-util/catfish/Manifest
@@ -1 +1,2 @@
DIST catfish-1.2.2.tar.bz2 98956 BLAKE2B a04c7c62745eb5ac5bc8a169fa01e9a943e319cd0d96db44485b12367838f5ec587a7fdf2be4cba4c135f8d301fe2b72c26646f0f97cb69404b7e6b682f817cc SHA512 dad407f1e818b8d537b73e9f832c39ca4f9527b9d636da18493a685b03d2fab56982a11872382fd457b9a1a0ffb33d29ade4aa317561c3b2ee82c96728705e75
+DIST catfish-1.4.6.tar.bz2 150331 BLAKE2B fb59dfce5770ddfb7740f1f7b2deb22928f3bd49a1ac323827143fc6c41586adbe45521daae3b26bf748f14c859051bae43ea4f94a0be37c84b30f933f7a2bca SHA512 1c50375a9b36554123327a138c50de47abbbfd2fb334b91773312e9001e4bbc936550c2b23ad658b29fe9f1537d59997513b01bf4e2c31ce0286f5650776f8f7
diff --git a/dev-util/catfish/catfish-1.4.6.ebuild b/dev-util/catfish/catfish-1.4.6.ebuild
new file mode 100644
index 000000000000..034f5d1e4621
--- /dev/null
+++ b/dev-util/catfish/catfish-1.4.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 gnome2-utils xdg-utils
+
+DESCRIPTION="A frontend for find, (s)locate, doodle, tracker, beagle, strigi and pinot"
+HOMEPAGE="https://docs.xfce.org/apps/catfish/start"
+SRC_URI="https://archive.xfce.org/src/apps/catfish/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ virtual/freedesktop-icon-theme
+"
+DEPEND="
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ sys-devel/gettext
+"
+
+python_install() {
+ distutils-r1_python_install
+ rm -r "${ED%/}"/usr/share/doc/catfish || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}