summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-26 17:52:52 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-26 20:24:37 +0200
commit9e07555d144ea2a0a9275eaa471c26d975f6bfc0 (patch)
tree7e7099e618382895bc3f2a256802e57858e9f52b /dev-util/catfish
parentvirtual/dist-kernel: Bump to 5.4.149 (diff)
downloadgentoo-9e07555d144ea2a0a9275eaa471c26d975f6bfc0.tar.gz
gentoo-9e07555d144ea2a0a9275eaa471c26d975f6bfc0.tar.bz2
gentoo-9e07555d144ea2a0a9275eaa471c26d975f6bfc0.zip
dev-util/catfish: Bump to 4.16.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/catfish')
-rw-r--r--dev-util/catfish/Manifest1
-rw-r--r--dev-util/catfish/catfish-4.16.3.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/catfish/Manifest b/dev-util/catfish/Manifest
index 65ec18760565..136a163b6abb 100644
--- a/dev-util/catfish/Manifest
+++ b/dev-util/catfish/Manifest
@@ -1,2 +1,3 @@
DIST catfish-4.16.0.tar.bz2 261252 BLAKE2B b495814857cb551c00dff8b92d2b24df876b1ab269bcb0ba468c791b97f3e962b875c5a687010472c5d47719475c99131d5ee6df3ce642af147b199976eb3538 SHA512 926318d3b2387386a5141347cf23b7e1505f83c48dac3804dc9c51aeeede2ef71d6d70e61bd5f608145249ccb4d3d87662bdab0c0a88dc69608b2edee55ddc19
DIST catfish-4.16.2.tar.bz2 270051 BLAKE2B 41048edc3933664af389ae7120e6f2b25f6c92632a4d00b999eef4e26e0f6eeeed70320ed740f26a0649e423e3b8316e33b8c671a282ae1a4474b3cc6bbc4824 SHA512 a1dc2839106d55e11e537478402b44d3794cdcf326c5984bd95d0d5a8bad52d91df1be22ba347d23f030d0c62fdf2b90a507e2abc30ed4b4d1804ab8dbde1dbe
+DIST catfish-4.16.3.tar.bz2 271642 BLAKE2B cebadeeb478a041ba6f815aec81b18d317ebf468bfe0699e33c4550a2f4b1b3377cbabd08d7d6504c3d94169b2be68d35ade9bd77e018ea7c099370ccf4ac124 SHA512 23ffa160b0593033a9696644fd00c48e4a6f54dc25448f975f0949aece50d8e4fbb45b9ad086a8e14072ac1dab27e0b4ecd19af0f31a5b4a775b17e18b00c7bb
diff --git a/dev-util/catfish/catfish-4.16.3.ebuild b/dev-util/catfish/catfish-4.16.3.ebuild
new file mode 100644
index 000000000000..e20eafa63bda
--- /dev/null
+++ b/dev-util/catfish/catfish-4.16.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A frontend for find, (s)locate, doodle, tracker, beagle, strigi and pinot"
+HOMEPAGE="https://docs.xfce.org/apps/catfish/start"
+SRC_URI="https://archive.xfce.org/src/apps/catfish/${PV%.*}/${P}.tar.bz2"
+
+# yep, GPL-2 only
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.42
+ dev-libs/gobject-introspection
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf[introspection]
+ >=x11-libs/gtk+-3.22:3[introspection]
+ x11-libs/pango[introspection]
+ >=xfce-base/xfconf-4.14[introspection]
+ virtual/freedesktop-icon-theme
+"
+BDEPEND="
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ sys-devel/gettext
+"
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+ rm -r "${ED}"/usr/share/doc/catfish || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}