summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-04-29 10:43:26 -0700
committerMatt Turner <mattst88@gentoo.org>2020-04-29 10:44:25 -0700
commitac5b5ef0678445ba9f4dd8d3c5bf7068fe5079c9 (patch)
treef3365a768ca3450f07405d67ae3d5aa0e5a15464 /dev-util/ccls/files
parentmedia-libs/mesa: Fix typo (diff)
downloadgentoo-ac5b5ef0678445ba9f4dd8d3c5bf7068fe5079c9.tar.gz
gentoo-ac5b5ef0678445ba9f4dd8d3c5bf7068fe5079c9.tar.bz2
gentoo-ac5b5ef0678445ba9f4dd8d3c5bf7068fe5079c9.zip
dev-util/ccls: Add patch to provide clang-10 support
Closes: https://bugs.gentoo.org/719334 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/ccls/files')
-rw-r--r--dev-util/ccls/files/ccls-0.20190823.6-cmake-support-CLANG_LINK_CLANG_DYLIB.patch57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-util/ccls/files/ccls-0.20190823.6-cmake-support-CLANG_LINK_CLANG_DYLIB.patch b/dev-util/ccls/files/ccls-0.20190823.6-cmake-support-CLANG_LINK_CLANG_DYLIB.patch
new file mode 100644
index 000000000000..e625ba814d8e
--- /dev/null
+++ b/dev-util/ccls/files/ccls-0.20190823.6-cmake-support-CLANG_LINK_CLANG_DYLIB.patch
@@ -0,0 +1,57 @@
+From 7e795e9b9ec20f02cab23e63d1e52189aa33ab4e Mon Sep 17 00:00:00 2001
+From: Fangrui Song <i@maskray.me>
+Date: Fri, 1 Nov 2019 10:36:38 -0700
+Subject: [PATCH] cmake: support CLANG_LINK_CLANG_DYLIB
+
+---
+ CMakeLists.txt | 34 +++++++++++++++++++---------------
+ 1 file changed, 19 insertions(+), 15 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 278e0735..092f178f 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -70,21 +70,25 @@ endif()
+
+ find_package(Clang REQUIRED)
+
+-target_link_libraries(ccls PRIVATE
+- clangIndex
+- clangFormat
+- clangTooling
+- clangToolingInclusions
+- clangToolingCore
+- clangFrontend
+- clangParse
+- clangSerialization
+- clangSema
+- clangAST
+- clangLex
+- clangDriver
+- clangBasic
+-)
++if(CLANG_LINK_CLANG_DYLIB)
++ target_link_libraries(ccls PRIVATE clang-cpp)
++else()
++ target_link_libraries(ccls PRIVATE
++ clangIndex
++ clangFormat
++ clangTooling
++ clangToolingInclusions
++ clangToolingCore
++ clangFrontend
++ clangParse
++ clangSerialization
++ clangSema
++ clangAST
++ clangLex
++ clangDriver
++ clangBasic
++ )
++endif()
+
+ if(LLVM_LINK_LLVM_DYLIB)
+ target_link_libraries(ccls PRIVATE LLVM)
+--
+2.26.2
+