summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-04-24 15:16:03 -0700
committerMatt Turner <mattst88@gentoo.org>2020-04-24 15:16:07 -0700
commit97a90dff776eb9b4f723fd47f44154626df8d100 (patch)
treeb6d58f29f43e0e66c99889d8d4bf56373d08e23f /dev-util/ccls
parentapp-forensics/honggfuzz: bump up to 2.2 (diff)
downloadgentoo-97a90dff776eb9b4f723fd47f44154626df8d100.tar.gz
gentoo-97a90dff776eb9b4f723fd47f44154626df8d100.tar.bz2
gentoo-97a90dff776eb9b4f723fd47f44154626df8d100.zip
dev-util/ccls: Version bump to 0.20190823.6
Closes: https://bugs.gentoo.org/712314 Closes: https://bugs.gentoo.org/714764 Closes: https://bugs.gentoo.org/719034 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/ccls')
-rw-r--r--dev-util/ccls/Manifest1
-rw-r--r--dev-util/ccls/ccls-0.20190823.6.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/ccls/Manifest b/dev-util/ccls/Manifest
index 84534b3e8acf..62b02853fd44 100644
--- a/dev-util/ccls/Manifest
+++ b/dev-util/ccls/Manifest
@@ -1 +1,2 @@
DIST ccls-0.20190823.5.tar.gz 158118 BLAKE2B 09b4a985a284fe74adc408eb9e86094aaf4ebfaf50de3238a17299efabe4749326b8239356c2808ca500a44bef664b2a654e9b16c83c3ef04cd7cf90c56fe3ef SHA512 3c4ecac663eb463870153734fa6206701ede9d72bae3b6eae9c26adab2979ad79d2ac860c1ffb07f8cfcea4aa63afed90510734d91f830c99a86b3811959583f
+DIST ccls-0.20190823.6.tar.gz 158158 BLAKE2B f2957b310f1bddc17a498191d315327adbeed72ecf3a60f2abde2fe1af8341246670d779807dcfaf98217f648d4fbe5914e4f64108cfe7a3f68e62b00e96dcaa SHA512 c6df96e304f5b7381c67eda4c1bd05873a85fb0d0983b3abcc507987a402860aa6660079a0e7b125f5cda22047da936239480aa0b604cd2598f84a4b9e9c3bdd
diff --git a/dev-util/ccls/ccls-0.20190823.6.ebuild b/dev-util/ccls/ccls-0.20190823.6.ebuild
new file mode 100644
index 000000000000..d959663fa6f0
--- /dev/null
+++ b/dev-util/ccls/ccls-0.20190823.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://github.com/MaskRay/${PN}"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit cmake ${GIT_ECLASS}
+
+DESCRIPTION="C/C++/ObjC language server"
+HOMEPAGE="https://github.com/MaskRay/ccls"
+
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/MaskRay/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-libs/rapidjson
+ sys-devel/clang:=
+ sys-devel/llvm:=
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_SYSTEM_RAPIDJSON=ON
+ )
+ cmake_src_configure
+}