summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/cdiff
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/cdiff')
-rw-r--r--dev-util/cdiff/Manifest2
-rw-r--r--dev-util/cdiff/cdiff-0.9.6.ebuild41
-rw-r--r--dev-util/cdiff/cdiff-0.9.7.ebuild40
-rw-r--r--dev-util/cdiff/cdiff-9999.ebuild41
-rw-r--r--dev-util/cdiff/files/cdiff-0.9.2-disable-unimportant-failing-test.patch11
-rw-r--r--dev-util/cdiff/metadata.xml15
6 files changed, 150 insertions, 0 deletions
diff --git a/dev-util/cdiff/Manifest b/dev-util/cdiff/Manifest
new file mode 100644
index 000000000000..f51d6d16dd1f
--- /dev/null
+++ b/dev-util/cdiff/Manifest
@@ -0,0 +1,2 @@
+DIST cdiff-0.9.6.tar.gz 30751 SHA256 a2fe898344f80ff5ecfd1d4bea7908422aeb0193f58b7669b485b8f7f978ae1b SHA512 8ae4d3dd26a53ba806f750736d7fcdddcae435d9492045e7ec57fa4b818125d0fe0f015d23910f393fa729b1c010ba3bf7bc5144f4794fe178a8a3e25d830480 WHIRLPOOL b799956392ea7b650b14d7073248a7a436281b5bbe6f11a53fe1c792543b46b279da24c795fb9bc49d1b4b35bee8518fd97e4486cc6cde3c8f932f828b2d35ce
+DIST cdiff-0.9.7.tar.gz 32061 SHA256 63b7f1037cbcf5ce76b56cd4e5643751e25e0c2a124bcd382af827651d81ca90 SHA512 2f2bf77ecc6e369325753c5d1c6fd23279138e8ae6a4d11cd102b5674d5c7e089e7f2613bbd39d68a00b0db16c589df64af14746228e38065556d0eb11b1e0cd WHIRLPOOL c26cb5df0b02b3567fa334ab2fe131ee99742b782d1bc8e83a4f06476c03d8242bbdc8489cec07ffb49ada0f5404c192c69765e3d9835fdf5feb944f8bb0e703
diff --git a/dev-util/cdiff/cdiff-0.9.6.ebuild b/dev-util/cdiff/cdiff-0.9.6.ebuild
new file mode 100644
index 000000000000..251fa11f3f55
--- /dev/null
+++ b/dev-util/cdiff/cdiff-0.9.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+if [[ "${PV}" != *"9999"* ]] ; then
+ KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+else
+ KEYWORDS=""
+ EGIT_REPO_URI="https://github.com/ymattw/cdiff.git"
+ inherit git-r3
+fi
+
+DESCRIPTION="Colored, side-by-side diff terminal viewer"
+HOMEPAGE="https://github.com/ymattw/${PN}"
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="
+ !<app-misc/colordiff-1.0.13-r1
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sys-apps/less"
+
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.9.2-disable-unimportant-failing-test.patch )
+
+DOCS=( CHANGES.rst README.rst )
+
+python_test() {
+ ${PYTHON} tests/test_cdiff.py || die "Unit tests failed."
+
+ ./tests/regression.sh || die "Regression tests failed."
+}
diff --git a/dev-util/cdiff/cdiff-0.9.7.ebuild b/dev-util/cdiff/cdiff-0.9.7.ebuild
new file mode 100644
index 000000000000..e867540dd43f
--- /dev/null
+++ b/dev-util/cdiff/cdiff-0.9.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+if [[ "${PV}" != *"9999"* ]] ; then
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+else
+ KEYWORDS=""
+ EGIT_REPO_URI="https://github.com/ymattw/cdiff.git"
+ inherit git-r3
+fi
+
+DESCRIPTION="Colored, side-by-side diff terminal viewer"
+HOMEPAGE="https://github.com/ymattw/${PN}"
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="
+ !<app-misc/colordiff-1.0.13-r1
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sys-apps/less"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.9.2-disable-unimportant-failing-test.patch )
+
+DOCS=( CHANGES.rst README.rst )
+
+python_test() {
+ ${PYTHON} tests/test_cdiff.py || die "Unit tests failed."
+
+ ./tests/regression.sh || die "Regression tests failed."
+}
diff --git a/dev-util/cdiff/cdiff-9999.ebuild b/dev-util/cdiff/cdiff-9999.ebuild
new file mode 100644
index 000000000000..8bbe3dd2c8cc
--- /dev/null
+++ b/dev-util/cdiff/cdiff-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+if [[ "${PV}" != *"9999"* ]] ; then
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+else
+ KEYWORDS=""
+ EGIT_REPO_URI="https://github.com/ymattw/cdiff.git"
+ inherit git-r3
+fi
+
+DESCRIPTION="Colored, side-by-side diff terminal viewer"
+HOMEPAGE="https://github.com/ymattw/${PN}"
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="
+ !<app-misc/colordiff-1.0.13-r1
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sys-apps/less"
+
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.9.2-disable-unimportant-failing-test.patch )
+
+DOCS=( CHANGES.rst README.rst )
+
+python_test() {
+ ${PYTHON} tests/test_cdiff.py || die "Unit tests failed."
+
+ ./tests/regression.sh || die "Regression tests failed."
+}
diff --git a/dev-util/cdiff/files/cdiff-0.9.2-disable-unimportant-failing-test.patch b/dev-util/cdiff/files/cdiff-0.9.2-disable-unimportant-failing-test.patch
new file mode 100644
index 000000000000..50b00cc5a46e
--- /dev/null
+++ b/dev-util/cdiff/files/cdiff-0.9.2-disable-unimportant-failing-test.patch
@@ -0,0 +1,11 @@
+--- a/tests/test_cdiff.py 2013-03-24 15:08:00.000000000 +0100
++++ b/tests/test_cdiff.py 2013-06-23 01:17:20.560520188 +0200
+@@ -737,7 +737,7 @@
+ os.chdir(self._non_ws)
+ ret = cdiff.main()
+ os.chdir(self._cwd)
+- self.assertNotEqual(ret, 0)
++# self.assertNotEqual(ret, 0)
+
+ def test_read_log(self):
+ sys.argv = [sys.argv[0], '--log']
diff --git a/dev-util/cdiff/metadata.xml b/dev-util/cdiff/metadata.xml
new file mode 100644
index 000000000000..72bbf530e00f
--- /dev/null
+++ b/dev-util/cdiff/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+ <longdescription>
+ Colored, side-by-side diff terminal viewer.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">cdiff</remote-id>
+ <remote-id type="github">ymattw/cdiff</remote-id>
+ </upstream>
+</pkgmetadata>