summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-01-24 23:23:41 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-01-24 23:24:48 +0100
commit791829506b64ae5bb8207aaccb8ae60f0b3ff762 (patch)
tree1e646acced4066a70221d57e8487054c50e7bba2 /dev-util/cgdb
parentdev-util/cgdb: add 0.8.0 (diff)
downloadgentoo-791829506b64ae5bb8207aaccb8ae60f0b3ff762.tar.gz
gentoo-791829506b64ae5bb8207aaccb8ae60f0b3ff762.tar.bz2
gentoo-791829506b64ae5bb8207aaccb8ae60f0b3ff762.zip
dev-util/cgdb: Sync live ebuild
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-util/cgdb')
-rw-r--r--dev-util/cgdb/cgdb-9999.ebuild22
-rw-r--r--dev-util/cgdb/files/cgdb-9999-ar.patch (renamed from dev-util/cgdb/files/cgdb-9999-respect-AR.patch)0
2 files changed, 13 insertions, 9 deletions
diff --git a/dev-util/cgdb/cgdb-9999.ebuild b/dev-util/cgdb/cgdb-9999.ebuild
index 75f88b51bff1..416db639d484 100644
--- a/dev-util/cgdb/cgdb-9999.ebuild
+++ b/dev-util/cgdb/cgdb-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="https://github.com/cgdb/cgdb.git"
inherit git-r3
+ EGIT_REPO_URI="https://github.com/cgdb/cgdb.git"
else
SRC_URI="https://github.com/cgdb/cgdb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
@@ -15,16 +15,17 @@ inherit autotools multilib-minimal
DESCRIPTION="A curses front-end for GDB, the GNU debugger"
HOMEPAGE="https://cgdb.github.io/"
+
LICENSE="GPL-2"
SLOT="0"
IUSE="test"
-RESTRICT="!test? ( test )"
+# Tests are broken, need additional research to figure out the cause
+# Bug: https://bugs.gentoo.org/831899
+RESTRICT="test"
DEPEND="
- sys-libs/ncurses:=
+ sys-libs/ncurses:0=
sys-libs/readline:0="
-RDEPEND="${DEPEND}
- sys-devel/gdb"
BDEPEND="
test? (
@@ -32,11 +33,14 @@ BDEPEND="
app-misc/dtach
)"
+RDEPEND="
+ ${DEPEND}
+ sys-devel/gdb"
+
DOCS=( AUTHORS ChangeLog FAQ INSTALL NEWS README.md )
PATCHES=(
- # Bug: #724256
- "${FILESDIR}/${P}-respect-AR.patch"
+ "${FILESDIR}"/${P}-ar.patch
)
src_prepare() {
diff --git a/dev-util/cgdb/files/cgdb-9999-respect-AR.patch b/dev-util/cgdb/files/cgdb-9999-ar.patch
index ed5f200b3260..ed5f200b3260 100644
--- a/dev-util/cgdb/files/cgdb-9999-respect-AR.patch
+++ b/dev-util/cgdb/files/cgdb-9999-ar.patch