summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-01-13 15:53:23 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-01-13 15:56:58 +0100
commit29af2219c2c5ea7516c8d026c62cd0cbe5e813cc (patch)
tree36d274b1476b67ddbdba8c7cbdfcc4f8a773ef77 /dev-util/checkbashisms/checkbashisms-2.17.0.ebuild
parentmedia-video/ffmpegthumbnailer: amd64 stable wrt bug #575520 (diff)
downloadgentoo-29af2219c2c5ea7516c8d026c62cd0cbe5e813cc.tar.gz
gentoo-29af2219c2c5ea7516c8d026c62cd0cbe5e813cc.tar.bz2
gentoo-29af2219c2c5ea7516c8d026c62cd0cbe5e813cc.zip
dev-util/checkbashisms: Bump to version 2.17.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-util/checkbashisms/checkbashisms-2.17.0.ebuild')
-rw-r--r--dev-util/checkbashisms/checkbashisms-2.17.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/checkbashisms/checkbashisms-2.17.0.ebuild b/dev-util/checkbashisms/checkbashisms-2.17.0.ebuild
new file mode 100644
index 000000000000..d163fdf1d322
--- /dev/null
+++ b/dev-util/checkbashisms/checkbashisms-2.17.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_PN="devscripts"
+MY_P="${MY_PN}-${PV}"
+
+inherit eutils
+
+DESCRIPTION="Perl script to check for commonly used bash features not defined by POSIX"
+HOMEPAGE="https://packages.debian.org/devscripts https://anonscm.debian.org/cgit/collab-maint/devscripts.git"
+SRC_URI="mirror://debian/pool/main/d/${MY_PN}/${MY_P/-/_}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Requires python packages to check tools we don't need anyway
+RESTRICT="test"
+
+RDEPEND="dev-lang/perl
+ virtual/perl-Getopt-Long
+ !<dev-util/rpmdevtools-8.3-r1"
+
+S="${WORKDIR}/${MY_P}/scripts"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.15.9-command-vV.patch
+)
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+}
+
+src_compile() { :; }
+
+src_install() {
+ newbin ${PN}.pl ${PN}
+ doman ${PN}.1
+}