summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-10-21 14:27:31 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-10-21 14:27:47 +0200
commitef94ea266cc5217d375ff0663b703a05bdc92e80 (patch)
treecca94e3a92a69fe8c092a002894ac15f9e43b2b0 /dev-util/checkbashisms/checkbashisms-2.19.7.ebuild
parentsys-process/dcron: ppc stable wrt bug #698134 (diff)
downloadgentoo-ef94ea266cc5217d375ff0663b703a05bdc92e80.tar.gz
gentoo-ef94ea266cc5217d375ff0663b703a05bdc92e80.tar.bz2
gentoo-ef94ea266cc5217d375ff0663b703a05bdc92e80.zip
dev-util/checkbashisms: Bump to version 2.19.7
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-util/checkbashisms/checkbashisms-2.19.7.ebuild')
-rw-r--r--dev-util/checkbashisms/checkbashisms-2.19.7.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/checkbashisms/checkbashisms-2.19.7.ebuild b/dev-util/checkbashisms/checkbashisms-2.19.7.ebuild
new file mode 100644
index 000000000000..e48d94ca95a3
--- /dev/null
+++ b/dev-util/checkbashisms/checkbashisms-2.19.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="devscripts"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Perl script to check for commonly used bash features not defined by POSIX"
+HOMEPAGE="https://packages.debian.org/devscripts https://anonscm.debian.org/cgit/collab-maint/devscripts.git"
+SRC_URI="mirror://debian/pool/main/d/${MY_PN}/${MY_P/-/_}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Requires python packages to check tools we don't need anyway
+RESTRICT="test"
+
+RDEPEND="dev-lang/perl
+ virtual/perl-Getopt-Long
+ !<dev-util/rpmdevtools-8.3-r1"
+
+S="${WORKDIR}/${MY_P}/scripts"
+
+src_prepare() {
+ default
+
+ eapply -p2 "${FILESDIR}"/${PN}-2.18.6-command-vV.patch
+
+ sed "s@###VERSION###@${PV}@" -i checkbashisms.pl || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ newbin ${PN}.pl ${PN}
+ doman ${PN}.1
+}