summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-04-30 17:23:27 -0500
committerMatthias Maier <tamiko@gentoo.org>2020-04-30 17:23:27 -0500
commitdb436e0d7f0c090d3f7793bb5ab76205818175a8 (patch)
treebfe00a9f4014d8bea24852f22be7b592528a58db /dev-util/cloc/cloc-1.84.ebuild
parentsci-libs/ginkgo: improve ebuild (diff)
downloadgentoo-db436e0d7f0c090d3f7793bb5ab76205818175a8.tar.gz
gentoo-db436e0d7f0c090d3f7793bb5ab76205818175a8.tar.bz2
gentoo-db436e0d7f0c090d3f7793bb5ab76205818175a8.zip
dev-util/cloc: version bump to 1.84, rekeyword (ALLARCHES policy)
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-util/cloc/cloc-1.84.ebuild')
-rw-r--r--dev-util/cloc/cloc-1.84.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/cloc/cloc-1.84.ebuild b/dev-util/cloc/cloc-1.84.ebuild
new file mode 100644
index 000000000000..61220333dbd9
--- /dev/null
+++ b/dev-util/cloc/cloc-1.84.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Count Lines of Code"
+HOMEPAGE="https://github.com/AlDanial/cloc"
+SRC_URI="https://github.com/AlDanial/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ dev-perl/Algorithm-Diff
+ dev-perl/Parallel-ForkManager
+ dev-perl/Regexp-Common
+ virtual/perl-Digest-MD5
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-Getopt-Long"
+
+src_compile() {
+ pod2man "Unix/${PN}.1.pod" > "${PN}.1" || die
+}
+
+src_install() {
+ doman "${PN}.1"
+ dobin "Unix/${PN}"
+}