summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-05-26 13:30:59 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-05-26 13:32:35 +0200
commit2358d1d626fc0d6dbaf3ddab9932671498d27099 (patch)
tree4c91d7c93849415c05bc3fbd4dbc975287961a43 /dev-util/cmake
parentapp-text/bibletime: update explanation of RESTRICT=test (diff)
downloadgentoo-2358d1d626fc0d6dbaf3ddab9932671498d27099.tar.gz
gentoo-2358d1d626fc0d6dbaf3ddab9932671498d27099.tar.bz2
gentoo-2358d1d626fc0d6dbaf3ddab9932671498d27099.zip
dev-util/cmake: Revbump to add boost-1.76 support
Bug: https://bugs.gentoo.org/791712 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-util/cmake')
-rw-r--r--dev-util/cmake/cmake-3.20.2-r1.ebuild (renamed from dev-util/cmake/cmake-3.20.2.ebuild)1
-rw-r--r--dev-util/cmake/files/cmake-3.20.2-boost-1.76.patch46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/cmake/cmake-3.20.2.ebuild b/dev-util/cmake/cmake-3.20.2-r1.ebuild
index 95de22ba838f..627ca4f7a027 100644
--- a/dev-util/cmake/cmake-3.20.2.ebuild
+++ b/dev-util/cmake/cmake-3.20.2-r1.ebuild
@@ -71,6 +71,7 @@ PATCHES=(
# upstream fixes (can usually be removed with a version bump)
"${FILESDIR}"/${P}-sphinx-4.patch # bug 789375
+ "${FILESDIR}"/${P}-boost-1.76.patch # bug 791712
)
cmake_src_bootstrap() {
diff --git a/dev-util/cmake/files/cmake-3.20.2-boost-1.76.patch b/dev-util/cmake/files/cmake-3.20.2-boost-1.76.patch
new file mode 100644
index 000000000000..898f8a75d7e0
--- /dev/null
+++ b/dev-util/cmake/files/cmake-3.20.2-boost-1.76.patch
@@ -0,0 +1,46 @@
+From 79be37b94e7353ec056e6343ba293ce1b60627d4 Mon Sep 17 00:00:00 2001
+From: Brad King <brad.king@kitware.com>
+Date: Fri, 7 May 2021 08:51:40 -0400
+Subject: [PATCH] FindBoost: Add support for Boost 1.76
+
+Update the list of known versions.
+
+Run the command
+
+ cmake -DBOOST_DIR=/path/to/boost_1_76_0 \
+ -P Utilities/Scripts/BoostScanDeps.cmake
+
+to extract dependencies from the 1.76.0 source tree.
+They are the same as 1.75's dependencies, so just update
+the version check for warning about newer versions.
+
+Fixes: #22167
+---
+ Modules/FindBoost.cmake | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Modules/FindBoost.cmake b/Modules/FindBoost.cmake
+index f8887ad2be..d31f925cb6 100644
+--- a/Modules/FindBoost.cmake
++++ b/Modules/FindBoost.cmake
+@@ -1350,7 +1350,7 @@ function(_Boost_COMPONENT_DEPENDENCIES component _ret)
+ set(_Boost_TIMER_DEPENDENCIES chrono)
+ set(_Boost_WAVE_DEPENDENCIES filesystem serialization thread chrono date_time atomic)
+ set(_Boost_WSERIALIZATION_DEPENDENCIES serialization)
+- if(Boost_VERSION_STRING VERSION_GREATER_EQUAL 1.76.0 AND NOT Boost_NO_WARN_NEW_VERSIONS)
++ if(Boost_VERSION_STRING VERSION_GREATER_EQUAL 1.77.0 AND NOT Boost_NO_WARN_NEW_VERSIONS)
+ message(WARNING "New Boost version may have incorrect or missing dependencies and imported targets")
+ endif()
+ endif()
+@@ -1622,7 +1622,7 @@ else()
+ # _Boost_COMPONENT_HEADERS. See the instructions at the top of
+ # _Boost_COMPONENT_DEPENDENCIES.
+ set(_Boost_KNOWN_VERSIONS ${Boost_ADDITIONAL_VERSIONS}
+- "1.75.0" "1.75" "1.74.0" "1.74"
++ "1.76.0" "1.76" "1.75.0" "1.75" "1.74.0" "1.74"
+ "1.73.0" "1.73" "1.72.0" "1.72" "1.71.0" "1.71" "1.70.0" "1.70" "1.69.0" "1.69"
+ "1.68.0" "1.68" "1.67.0" "1.67" "1.66.0" "1.66" "1.65.1" "1.65.0" "1.65"
+ "1.64.0" "1.64" "1.63.0" "1.63" "1.62.0" "1.62" "1.61.0" "1.61" "1.60.0" "1.60"
+--
+GitLab
+