summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorband-a-prend <torokhov-s-a@yandex.ru>2018-04-27 03:51:57 +0300
committerMart Raudsepp <leio@gentoo.org>2018-05-05 23:09:14 +0300
commit8597839fe14042f30a08c3d57574566ba8a5d8f7 (patch)
tree9ab149ee720320ef6eefa24e1ef3e5e43da139c5 /dev-util/codeblocks/codeblocks-17.12-r300.ebuild
parentprofiles/package.mask: add codeblocks-17.12-r300 (diff)
downloadgentoo-8597839fe14042f30a08c3d57574566ba8a5d8f7.tar.gz
gentoo-8597839fe14042f30a08c3d57574566ba8a5d8f7.tar.bz2
gentoo-8597839fe14042f30a08c3d57574566ba8a5d8f7.zip
dev-util/codeblocks: ver. 17.12 for wxGTK:3.0-gtk3
Adding additional 'codeblocks-17.12-r300.ebuild' for building with wxGTK:3.0-gtk3 instead of wxGTK:2.8. This also contains USE flag 'fortran' (introduced in codeblocks-17.12.ebuild ) which controls the building of 'FortranProject plugin' for Code::Blocks IDE ( https://sourceforge.net/projects/fortranproject/ ) after applying of 'FortranProject_autotools_build.diff' patch. Bug: bugs.gentoo.org/643494
Diffstat (limited to 'dev-util/codeblocks/codeblocks-17.12-r300.ebuild')
-rw-r--r--dev-util/codeblocks/codeblocks-17.12-r300.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/dev-util/codeblocks/codeblocks-17.12-r300.ebuild b/dev-util/codeblocks/codeblocks-17.12-r300.ebuild
new file mode 100644
index 000000000000..7470b026d378
--- /dev/null
+++ b/dev-util/codeblocks/codeblocks-17.12-r300.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools flag-o-matic gnome2-utils wxwidgets xdg-utils
+
+DESCRIPTION="The open source, cross platform, free C++ IDE"
+HOMEPAGE="http://www.codeblocks.org/"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
+SRC_URI="mirror://sourceforge/${PN}/${P/-/_}.tar.xz https://dev.gentoo.org/~leio/distfiles/${P}-fortran.tar.xz"
+
+# USE="fortran" enables FortranProject plugin (v1.5)
+# that is delivered with Code::Blocks 17.12 source code.
+# https://sourceforge.net/projects/fortranproject
+# http://cbfortran.sourceforge.net
+
+IUSE="contrib debug fortran pch"
+
+RDEPEND="app-arch/zip
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ contrib? (
+ app-text/hunspell
+ dev-libs/boost:=
+ dev-libs/libgamin
+ )"
+
+DEPEND="${RDEPEND}
+ sys-devel/autoconf:2.69
+ sys-devel/automake
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/codeblocks-17.12-nodebug.diff
+ "${WORKDIR}"/patches/
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ setup-wxwidgets
+
+ append-cxxflags $(test-flags-CXX -fno-delete-null-pointer-checks)
+
+ # USE="contrib -fortran" setup:
+ use fortran || CONF_WITH_LST=$(use_with contrib contrib-plugins all,-FortranProject)
+ # USE="contrib fortran" setup:
+ use fortran && CONF_WITH_LST=$(use_with contrib contrib-plugins all)
+ # USE="-contrib fortran" setup:
+ use contrib || CONF_WITH_LST=$(use_with fortran contrib-plugins FortranProject)
+
+ econf \
+ --with-wx-config="${WX_CONFIG}" \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable pch) \
+ ${CONF_WITH_LST}
+}
+
+pkg_postinst() {
+ if [[ ${WX_GTK_VER} == "3.0" || ${WX_GTK_VER} == "3.0-gtk3" ]]; then
+ elog "KNOWN ISSUE:"
+ elog "The symbols browser is disabled in wx3.x builds due to it causes crashes."
+ elog "For more information see ticket https://sourceforge.net/p/codeblocks/tickets/225/"
+ elog "with related commits https://sourceforge.net/p/codeblocks/code/11027/"
+ elog "and https://sourceforge.net/p/codeblocks/code/11141/"
+ fi
+
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}