summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorband-a-prend <torokhov-s-a@yandex.ru>2020-10-14 18:29:49 +0300
committerSergei Trofimovich <slyfox@gentoo.org>2020-10-14 19:35:08 +0100
commit56d8bafba4d7c3431ebcbd05492f0b16b5ce8001 (patch)
treed6a4b576bdf0b14f3feb03b8d453ee3df479b0b2 /dev-util/codeblocks/codeblocks-20.03-r2.ebuild
parentdev-libs/gumbo: ppc64 keyworded (bug #748558) (diff)
downloadgentoo-56d8bafba4d7c3431ebcbd05492f0b16b5ce8001.tar.gz
gentoo-56d8bafba4d7c3431ebcbd05492f0b16b5ce8001.tar.bz2
gentoo-56d8bafba4d7c3431ebcbd05492f0b16b5ce8001.zip
dev-util/codeblocks: fix gcc-11 compatibility
The GCC 11 now enforces that comparison objects be invocable as const. Current patch to fix gcc-11 compatibility is proposed by Sergei Trofimovich <slyfox@gentoo.org> and fix codeblocks "openfileslist" pligin compilation error. Patch was sent to upstream : https://sourceforge.net/p/codeblocks/tickets/1022/ so live-ebuild currently doesn't apply it. Closes: https://bugs.gentoo.org/732818 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/17928 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util/codeblocks/codeblocks-20.03-r2.ebuild')
-rw-r--r--dev-util/codeblocks/codeblocks-20.03-r2.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/dev-util/codeblocks/codeblocks-20.03-r2.ebuild b/dev-util/codeblocks/codeblocks-20.03-r2.ebuild
new file mode 100644
index 000000000000..16fbd94b7720
--- /dev/null
+++ b/dev-util/codeblocks/codeblocks-20.03-r2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools wxwidgets xdg
+
+DESCRIPTION="The open source, cross platform, free C, C++ and Fortran IDE"
+HOMEPAGE="https://codeblocks.org/"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz
+https://dev.gentoo.org/~leio/distfiles/${P}-fortran.tar.xz
+https://dev.gentoo.org/~leio/distfiles/${P}-fortran-update-v1.7.tar.xz"
+
+# USE="fortran" enables FortranProject plugin (updated to v1.7 2020-06-07 [r298])
+# that is delivered with Code::Blocks 20.03 source code.
+# https://sourceforge.net/projects/fortranproject
+# https://cbfortran.sourceforge.io
+
+IUSE="contrib debug fortran pch"
+
+BDEPEND="virtual/pkgconfig"
+
+RDEPEND="app-arch/zip
+ >=dev-libs/tinyxml-2.6.2-r3
+ >=dev-util/astyle-3.1-r2:0/3.1
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ contrib? (
+ app-admin/gamin
+ app-text/hunspell
+ dev-libs/boost:=
+ )"
+
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-env.patch
+ "${FILESDIR}"/${P}_gcc11_compatibility.patch
+ "${WORKDIR}"/patches/
+ )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ setup-wxwidgets
+
+ # USE="contrib -fortran" setup:
+ use fortran || CONF_WITH_LST=$(use_with contrib contrib-plugins all,-FortranProject)
+ # USE="contrib fortran" setup:
+ use fortran && CONF_WITH_LST=$(use_with contrib contrib-plugins all)
+ # USE="-contrib fortran" setup:
+ use contrib || CONF_WITH_LST=$(use_with fortran contrib-plugins FortranProject)
+
+ econf \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable pch) \
+ ${CONF_WITH_LST}
+}
+
+pkg_postinst() {
+ elog "The Symbols Browser is disabled due to it causing crashes."
+ elog "For more information see https://sourceforge.net/p/codeblocks/tickets/225/"
+
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}