summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-07-05 20:09:21 -0400
committerCraig Andrews <candrews@gentoo.org>2019-07-05 20:40:55 -0400
commit34e563862212b0f4e26a451220355957f3cd6d74 (patch)
treee507570fd91c34d26bd92106eb1b199f24ed545a /dev-util/conf2struct/conf2struct-9999.ebuild
parentdev-perl/Conf-Libconfig: Perl extension for libconfig (diff)
downloadgentoo-34e563862212b0f4e26a451220355957f3cd6d74.tar.gz
gentoo-34e563862212b0f4e26a451220355957f3cd6d74.tar.bz2
gentoo-34e563862212b0f4e26a451220355957f3cd6d74.zip
dev-util/conf2struct: Create C parsers for libconfig and command-line
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-util/conf2struct/conf2struct-9999.ebuild')
-rw-r--r--dev-util/conf2struct/conf2struct-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/conf2struct/conf2struct-9999.ebuild b/dev-util/conf2struct/conf2struct-9999.ebuild
new file mode 100644
index 000000000000..3ab3bce60c3a
--- /dev/null
+++ b/dev-util/conf2struct/conf2struct-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic systemd toolchain-funcs
+
+DESCRIPTION="Create C parsers for libconfig and command-line"
+HOMEPAGE="https://github.com/yrutschle/conf2struct/"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/yrutschle/conf2struct.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/yrutschle/conf2struct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="caps pcre systemd tcpd"
+
+RDEPEND="dev-libs/libconfig
+ dev-perl/Conf-Libconfig"
+DEPEND="${RDEPEND}"
+
+src_install(){
+ emake DESTDIR="${D}" prefix="${EPREFIX%/}/usr" install
+}