summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2017-10-29 14:11:57 +0100
committerCédric Krier <cedk@gentoo.org>2017-10-29 14:11:57 +0100
commit4df908b29cf97e728c5217f1e405ed65c87bdae0 (patch)
tree1d453f5b080420588a29d39f496f386ba0364db1 /dev-util/cookiecutter/cookiecutter-1.6.0.ebuild
parentdev-python/zeep: Version bumps (diff)
downloadgentoo-4df908b29cf97e728c5217f1e405ed65c87bdae0.tar.gz
gentoo-4df908b29cf97e728c5217f1e405ed65c87bdae0.tar.bz2
gentoo-4df908b29cf97e728c5217f1e405ed65c87bdae0.zip
dev-util/cookiecutter: Version bumps
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-util/cookiecutter/cookiecutter-1.6.0.ebuild')
-rw-r--r--dev-util/cookiecutter/cookiecutter-1.6.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/cookiecutter/cookiecutter-1.6.0.ebuild b/dev-util/cookiecutter/cookiecutter-1.6.0.ebuild
new file mode 100644
index 000000000000..5981c6b95265
--- /dev/null
+++ b/dev-util/cookiecutter/cookiecutter-1.6.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Command-line utility to create projects from cookiecutters (project templates)"
+HOMEPAGE="https://github.com/audreyr/cookiecutter"
+
+SRC_URI="https://github.com/audreyr/cookiecutter/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=">=dev-python/future-0.15.2[${PYTHON_USEDEP}]
+ >=dev-python/binaryornot-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ >=dev-python/click-5.0[${PYTHON_USEDEP}]
+ >=dev-python/whichcraft-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/poyo-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja2-time-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.1[${PYTHON_USEDEP}]
+ dev-python/pytest-catchlog[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}] )"
+
+DOCS=( README.rst HISTORY.rst CONTRIBUTING.rst )
+
+python_test() {
+ py.test || die
+}