summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2020-05-08 21:59:50 +0200
committerCédric Krier <cedk@gentoo.org>2020-05-08 22:00:32 +0200
commitb73717326bbaad782ae3927c32a376d319f04293 (patch)
treef3f2cfe8c9f20633ca83ee750d02624f6fe3b207 /dev-util/cookiecutter/cookiecutter-1.7.2.ebuild
parentsys-cluster/swift: fully remove tests (diff)
downloadgentoo-b73717326bbaad782ae3927c32a376d319f04293.tar.gz
gentoo-b73717326bbaad782ae3927c32a376d319f04293.tar.bz2
gentoo-b73717326bbaad782ae3927c32a376d319f04293.zip
dev-util/cookiecutter: Version bumps
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Cédric Krier <cedk@gentoo.org>
Diffstat (limited to 'dev-util/cookiecutter/cookiecutter-1.7.2.ebuild')
-rw-r--r--dev-util/cookiecutter/cookiecutter-1.7.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/cookiecutter/cookiecutter-1.7.2.ebuild b/dev-util/cookiecutter/cookiecutter-1.7.2.ebuild
new file mode 100644
index 000000000000..69fab484d8e2
--- /dev/null
+++ b/dev-util/cookiecutter/cookiecutter-1.7.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Command-line utility to create projects from cookiecutters (project templates)"
+HOMEPAGE="https://github.com/audreyr/cookiecutter"
+
+SRC_URI="https://github.com/audreyr/cookiecutter/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/binaryornot-0.4.4[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ <dev-python/jinja-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/poyo-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja2-time-0.2.0[${PYTHON_USEDEP}]
+ dev-python/python-slugify[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.23.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10[${PYTHON_USEDEP}]
+ <dev-python/markupsafe-2.0.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-vcs/git )"
+
+DOCS=( README.md HISTORY.md CONTRIBUTING.md )
+
+PATCHES=(
+ "${FILESDIR}/test_cli-1.7.2.patch"
+ )
+
+python_test() {
+ pytest -o addopts= || die
+}