summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2019-01-07 23:56:28 +0100
committerSebastian Pipping <sping@gentoo.org>2019-01-07 23:56:59 +0100
commit320111d412d7715c522790eaa1ddb832e1877341 (patch)
treebfe87829202a308e4f226127a807a815eecbd5c9 /dev-util/cpptest
parentapp-text/poppler: 0.73.0 version bump (diff)
downloadgentoo-320111d412d7715c522790eaa1ddb832e1877341.tar.gz
gentoo-320111d412d7715c522790eaa1ddb832e1877341.tar.bz2
gentoo-320111d412d7715c522790eaa1ddb832e1877341.zip
dev-util/cpptest: 2.0.0
Ping: https://github.com/cpptest/cpptest/issues/13 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'dev-util/cpptest')
-rw-r--r--dev-util/cpptest/Manifest1
-rw-r--r--dev-util/cpptest/cpptest-2.0.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/cpptest/Manifest b/dev-util/cpptest/Manifest
index 264667cb7363..f7b8c32798cd 100644
--- a/dev-util/cpptest/Manifest
+++ b/dev-util/cpptest/Manifest
@@ -1 +1,2 @@
DIST cpptest-1.1.2.tar.gz 458982 BLAKE2B dbb144196ec5726822f859397f5429e743bdc9bd840c2dab198f19512d2d0ff66b33e8b1018be2616944e300b0bc0e2fd247b7c7a5a290096f8d402592f1441b SHA512 da1030c69a5886e752b9ae08b65c501334c7d2d4abd2174190209ce11ed351239a615b9f7c5019ee601289523b2c21a1205d2042e59aea6c2882d77d636fc57a
+DIST cpptest-2.0.0.tar.bz2 440323 BLAKE2B 7d703a9a41c6fc355f97d2074b71fc5c700ee2483386984147c399c096eebeec7f2a980f0678e1a4d9979a7795d3f7ff7d70cbf8b483e055a420de985aa40f2e SHA512 41b5f7989198a79dca29f7d579c4d3918e5c3bbc0f91f77317ae074af8daaa8e5ee8add7c29c8e345cb95b08524839cecc7659a8d95ee95712e205b8838c5029
diff --git a/dev-util/cpptest/cpptest-2.0.0.ebuild b/dev-util/cpptest/cpptest-2.0.0.ebuild
new file mode 100644
index 000000000000..8369dad2328c
--- /dev/null
+++ b/dev-util/cpptest/cpptest-2.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Simple but powerful unit testing framework for C++"
+HOMEPAGE="https://github.com/cpptest/cpptest"
+SRC_URI="https://github.com/cpptest/cpptest/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="1" # for soversion 1.x.x
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND="!dev-util/cpptest:0"
+
+DOCS=( AUTHORS BUGS NEWS README )
+
+src_configure() {
+ econf \
+ $(use_enable doc) \
+ --htmldir=/usr/share/doc/${PF}/html/
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}