summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2023-05-12 20:34:32 +0800
committerYixun Lan <dlan@gentoo.org>2023-05-12 20:36:10 +0800
commita242be40e98cd29241a44d68b1b6bd421805aa5e (patch)
treea4c1ccc6c3fddf578ff0a5d047bdcf4578d96769 /dev-util/crash/crash-7.3.1.ebuild
parentdev-util/crash: add 8.0.3 (diff)
downloadgentoo-a242be40e98cd29241a44d68b1b6bd421805aa5e.tar.gz
gentoo-a242be40e98cd29241a44d68b1b6bd421805aa5e.tar.bz2
gentoo-a242be40e98cd29241a44d68b1b6bd421805aa5e.zip
dev-util/crash: drop 7.3.1, 8.0.0-r1, 8.0.1
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-util/crash/crash-7.3.1.ebuild')
-rw-r--r--dev-util/crash/crash-7.3.1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-util/crash/crash-7.3.1.ebuild b/dev-util/crash/crash-7.3.1.ebuild
deleted file mode 100644
index 70eac2d36095..000000000000
--- a/dev-util/crash/crash-7.3.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-GDB_VERSION=7.6
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/crash-utility/crash.git"
- SRC_URI="mirror://gnu/gdb/gdb-${GDB_VERSION}.tar.gz"
- EGIT_BRANCH="master"
- inherit git-r3
-else
- SRC_URI="https://github.com/crash-utility/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
- mirror://gnu/gdb/gdb-${GDB_VERSION}.tar.gz"
- KEYWORDS="-* ~alpha ~amd64 ~arm ~ia64 ~ppc64 ~s390 ~x86"
-fi
-
-DESCRIPTION="Red Hat crash utility; used for analyzing kernel core dumps"
-HOMEPAGE="https://crash-utility.github.io/"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE=""
-# there is no "make test" target, but there is a test.c so the automatic
-# make rules catch it and tests fail
-RESTRICT="test"
-
-src_prepare() {
- sed -i -e "s|ar -rs|\${AR} -rs|g" Makefile || die
- ln -s "${DISTDIR}"/gdb-7.6.tar.gz . || die
- default
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- AR="$(tc-getAR)" \
- CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
-}