summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-09 02:55:51 +0100
committerSam James <sam@gentoo.org>2022-04-09 02:55:51 +0100
commitf19a6f7a4644cc6ed45d2bd0b4b2594857c4aea4 (patch)
tree9a8f90f9504c54b38e0dce0324c8a917a2dae59f /dev-util/crash/crash-7.3.1.ebuild
parentapp-dicts/aspell-tet: use mirror://gnu (diff)
downloadgentoo-f19a6f7a4644cc6ed45d2bd0b4b2594857c4aea4.tar.gz
gentoo-f19a6f7a4644cc6ed45d2bd0b4b2594857c4aea4.tar.bz2
gentoo-f19a6f7a4644cc6ed45d2bd0b4b2594857c4aea4.zip
dev-util/crash: use mirror://gnu; use xz
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/crash/crash-7.3.1.ebuild')
-rw-r--r--dev-util/crash/crash-7.3.1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-util/crash/crash-7.3.1.ebuild b/dev-util/crash/crash-7.3.1.ebuild
index 24b0d3f6115c..6e0bb1556929 100644
--- a/dev-util/crash/crash-7.3.1.ebuild
+++ b/dev-util/crash/crash-7.3.1.ebuild
@@ -1,18 +1,19 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
+GDB_VERSION=7.6
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/crash-utility/crash.git"
- SRC_URI="http://ftp.gnu.org/gnu/gdb/gdb-7.6.tar.gz"
+ SRC_URI="mirror://gnu/gdb/gdb-${GDB_VERSION}.tar.bz2"
EGIT_BRANCH="master"
inherit git-r3
else
SRC_URI="https://github.com/crash-utility/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
- mirror://gnu/gdb/gdb-7.6.tar.gz"
+ mirror://gnu/gdb/gdb-${GDB_VERSION}.tar.bz2"
KEYWORDS="-* ~alpha ~amd64 ~arm ~ia64 ~ppc64 ~s390 ~x86"
fi