summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-04-21 14:23:42 +0200
committerMichał Górny <mgorny@gentoo.org>2019-04-21 14:37:33 +0200
commitd2f1a1a720e33f2448697e190c53ca56d937b946 (patch)
tree2c94cbacb23db0de87f8311b2da1260c8a7d33cd /dev-util/creduce/creduce-2.8.0.ebuild
parentdev-python/llvmlite: Fix building against LLVM 7.1.0 (diff)
downloadgentoo-d2f1a1a720e33f2448697e190c53ca56d937b946.tar.gz
gentoo-d2f1a1a720e33f2448697e190c53ca56d937b946.tar.bz2
gentoo-d2f1a1a720e33f2448697e190c53ca56d937b946.zip
dev-util/creduce: Bump to 2.8.0
Closes: https://bugs.gentoo.org/683356 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/creduce/creduce-2.8.0.ebuild')
-rw-r--r--dev-util/creduce/creduce-2.8.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/creduce/creduce-2.8.0.ebuild b/dev-util/creduce/creduce-2.8.0.ebuild
new file mode 100644
index 000000000000..5d6570d88f66
--- /dev/null
+++ b/dev-util/creduce/creduce-2.8.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+: ${CMAKE_MAKEFILE_GENERATOR=ninja}
+inherit cmake-utils llvm
+
+DESCRIPTION="C-Reduce - a plugin-based C program reducer"
+HOMEPAGE="https://embed.cs.utah.edu/creduce/"
+SRC_URI="https://embed.cs.utah.edu/creduce/${P}.tar.gz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+LLVM_MAX_SLOT=7
+
+COMMON_DEPEND="
+ >=dev-lang/perl-5.10.0
+ sys-devel/clang:${LLVM_MAX_SLOT}"
+RDEPEND="${COMMON_DEPEND}
+ dev-perl/Benchmark-Timer
+ dev-perl/Exporter-Lite
+ dev-perl/File-Which
+ dev-perl/Getopt-Tabular
+ dev-perl/Regexp-Common
+ dev-perl/Sys-CPU
+ dev-util/astyle
+ dev-util/indent"
+DEPEND="${COMMON_DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/creduce-llvm-7.patch
+ "${FILESDIR}"/creduce-2.8.0-link-libs.patch
+)
+
+llvm_check_deps() {
+ has_version "sys-devel/clang:${LLVM_SLOT}"
+}