summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-04-21 14:23:42 +0200
committerMichał Górny <mgorny@gentoo.org>2019-04-21 14:37:33 +0200
commitd2f1a1a720e33f2448697e190c53ca56d937b946 (patch)
tree2c94cbacb23db0de87f8311b2da1260c8a7d33cd /dev-util/creduce/files
parentdev-python/llvmlite: Fix building against LLVM 7.1.0 (diff)
downloadgentoo-d2f1a1a720e33f2448697e190c53ca56d937b946.tar.gz
gentoo-d2f1a1a720e33f2448697e190c53ca56d937b946.tar.bz2
gentoo-d2f1a1a720e33f2448697e190c53ca56d937b946.zip
dev-util/creduce: Bump to 2.8.0
Closes: https://bugs.gentoo.org/683356 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/creduce/files')
-rw-r--r--dev-util/creduce/files/creduce-2.8.0-link-libs.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/creduce/files/creduce-2.8.0-link-libs.patch b/dev-util/creduce/files/creduce-2.8.0-link-libs.patch
new file mode 100644
index 000000000000..25e9ef229165
--- /dev/null
+++ b/dev-util/creduce/files/creduce-2.8.0-link-libs.patch
@@ -0,0 +1,31 @@
+From 885a675474d93ae4ef929de7520d3ac38ba39156 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sun, 21 Apr 2019 14:20:34 +0200
+Subject: [PATCH] Revert "Do not list `LLVM_LIBS` in the
+ `target_link_libraries`."
+
+This breaks linking against shared LLVM.
+---
+ clang_delta/CMakeLists.txt | 6 +-----
+ 1 file changed, 1 insertion(+), 5 deletions(-)
+
+diff --git a/clang_delta/CMakeLists.txt b/clang_delta/CMakeLists.txt
+index 6493abf..ab1dc42 100644
+--- a/clang_delta/CMakeLists.txt
++++ b/clang_delta/CMakeLists.txt
+@@ -242,11 +242,7 @@ add_executable(clang_delta
+ git_version.h
+ )
+
+-# ENE, LLVM 6.0: LLVM_LIBS end up in the link command line anyway. I'm not
+-# quite sure why! But if you list LLVM_LIBS here, the `clang_delta' binary
+-# can end up with dynamic link errors when it runs (multiply defined symbols).
+-#
+-target_link_libraries(clang_delta ${CLANG_LIBS})
++target_link_libraries(clang_delta ${CLANG_LIBS} ${LLVM_LIBS})
+
+ # Custom target for running clang_delta tests
+ #
+--
+2.21.0
+