summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/ctags
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/ctags')
-rw-r--r--dev-util/ctags/Manifest2
-rw-r--r--dev-util/ctags/ctags-5.8-r1.ebuild64
-rw-r--r--dev-util/ctags/ctags-5.8.ebuild64
-rw-r--r--dev-util/ctags/files/ctags-5.6-ebuilds.patch22
-rw-r--r--dev-util/ctags/files/ctags-5.8-ada.patch28
-rw-r--r--dev-util/ctags/files/ctags-5.8-f95-pointers.patch12
-rw-r--r--dev-util/ctags/files/ctags-5.8-python-vars-starting-with-def.patch13
-rw-r--r--dev-util/ctags/metadata.xml11
8 files changed, 216 insertions, 0 deletions
diff --git a/dev-util/ctags/Manifest b/dev-util/ctags/Manifest
new file mode 100644
index 000000000000..92c894834698
--- /dev/null
+++ b/dev-util/ctags/Manifest
@@ -0,0 +1,2 @@
+DIST ctags-5.8.tar.gz 479927 SHA256 0e44b45dcabe969e0bbbb11e30c246f81abe5d32012db37395eb57d66e9e99c7 SHA512 981912cd335978cde22864e977947fc75326572fb29518e559cc4a8ac1edc84b3604165218a666e36353f17da4f89f8e967acdb88696f816748eb946d79eaa15 WHIRLPOOL 04506a4495025907ee5fe41b9c4ff104dd234fc9ef39bd594158b36c550bf511b6ab5980a98736f9857dc47b99f1718a7ae2928fd4a1d1c0b57dfd3d79fce2ea
+DIST ctags-ada-mode-4.3.11.tar.bz2 14060 SHA256 d25a3fd26b356adbd068f10a0b68691d36c154c04b96304b96386e169e4b6b57 SHA512 51c71e13ef658cd6682f04c94485315c4a702080ef2c7786fc9881b03c86f1c1d43aa1a69c452e4b0b2f7a78383804b66b159542cb4eae0cd309bc1ddbe2eb6e WHIRLPOOL 7e0ded8c97d3651e1afe48ec836697a4a19264baf3b203f6e98c134b88e3ab0eee7ac660789f5b955f0f827128996988694aa6c4bc78f18adf52724c5230da5d
diff --git a/dev-util/ctags/ctags-5.8-r1.ebuild b/dev-util/ctags/ctags-5.8-r1.ebuild
new file mode 100644
index 000000000000..c2fb30b158ba
--- /dev/null
+++ b/dev-util/ctags/ctags-5.8-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Exuberant Ctags creates tags files for code browsing in editors"
+HOMEPAGE="http://ctags.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ ada? ( mirror://sourceforge/gnuada/ctags-ada-mode-4.3.11.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="ada"
+
+RDEPEND="app-eselect/eselect-ctags"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-5.6-ebuilds.patch"
+ # Upstream fix for python variables starting with def
+ epatch "${FILESDIR}/${P}-python-vars-starting-with-def.patch"
+
+ # Bug #273697
+ epatch "${FILESDIR}/${P}-f95-pointers.patch"
+
+ # enabling Ada support
+ if use ada ; then
+ cp "${WORKDIR}/${PN}-ada-mode-4.3.11/ada.c" "${S}" || die
+ epatch "${FILESDIR}/${P}-ada.patch"
+ fi
+}
+
+src_configure() {
+ econf \
+ --with-posix-regex \
+ --without-readlib \
+ --disable-etags \
+ --enable-tmpdir=/tmp
+}
+
+src_install() {
+ emake prefix="${D}"/usr mandir="${D}"/usr/share/man install
+
+ # namepace collision with X/Emacs-provided /usr/bin/ctags -- we
+ # rename ctags to exuberant-ctags (Mandrake does this also).
+ mv "${D}"/usr/bin/{ctags,exuberant-ctags} || die
+ mv "${D}"/usr/share/man/man1/{ctags,exuberant-ctags}.1 || die
+
+ dodoc FAQ NEWS README
+ dohtml EXTENDING.html ctags.html
+}
+
+pkg_postinst() {
+ eselect ctags update
+ elog "You can set the version to be started by /usr/bin/ctags through"
+ elog "the ctags eselect module. \"man ctags.eselect\" for details."
+}
+
+pkg_postrm() {
+ eselect ctags update
+}
diff --git a/dev-util/ctags/ctags-5.8.ebuild b/dev-util/ctags/ctags-5.8.ebuild
new file mode 100644
index 000000000000..de4c1087cc37
--- /dev/null
+++ b/dev-util/ctags/ctags-5.8.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Exuberant Ctags creates tags files for code browsing in editors"
+HOMEPAGE="http://ctags.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ ada? ( mirror://sourceforge/gnuada/ctags-ada-mode-4.3.11.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="ada"
+
+DEPEND="app-eselect/eselect-ctags"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-5.6-ebuilds.patch"
+ # Upstream fix for python variables starting with def
+ epatch "${FILESDIR}/${P}-python-vars-starting-with-def.patch"
+
+ # Bug #273697
+ epatch "${FILESDIR}/${P}-f95-pointers.patch"
+
+ # enabling Ada support
+ if use ada ; then
+ cp "${WORKDIR}/${PN}-ada-mode-4.3.11/ada.c" "${S}" || die
+ epatch "${FILESDIR}/${P}-ada.patch"
+ fi
+}
+
+src_configure() {
+ econf \
+ --with-posix-regex \
+ --without-readlib \
+ --disable-etags \
+ --enable-tmpdir=/tmp
+}
+
+src_install() {
+ emake prefix="${D}"/usr mandir="${D}"/usr/share/man install
+
+ # namepace collision with X/Emacs-provided /usr/bin/ctags -- we
+ # rename ctags to exuberant-ctags (Mandrake does this also).
+ mv "${D}"/usr/bin/{ctags,exuberant-ctags} || die
+ mv "${D}"/usr/share/man/man1/{ctags,exuberant-ctags}.1 || die
+
+ dodoc FAQ NEWS README
+ dohtml EXTENDING.html ctags.html
+}
+
+pkg_postinst() {
+ eselect ctags update
+ elog "You can set the version to be started by /usr/bin/ctags through"
+ elog "the ctags eselect module. \"man ctags.eselect\" for details."
+}
+
+pkg_postrm() {
+ eselect ctags update
+}
diff --git a/dev-util/ctags/files/ctags-5.6-ebuilds.patch b/dev-util/ctags/files/ctags-5.6-ebuilds.patch
new file mode 100644
index 000000000000..5b0de663a15a
--- /dev/null
+++ b/dev-util/ctags/files/ctags-5.6-ebuilds.patch
@@ -0,0 +1,22 @@
+diff -ur ctags-5.6/sh.c ctags-5.6-ebuild/sh.c
+--- ctags-5.6/sh.c 2006-05-30 00:37:13.000000000 -0400
++++ ctags-5.6-ebuild/sh.c 2006-10-07 17:37:31.000000000 -0400
+@@ -7,7 +7,8 @@
+ * GNU General Public License.
+ *
+ * This module contains functions for generating tags for scripts for the
+-* Bourne shell (and its derivatives, the Korn and Z shells).
++* Bourne shell (and its derivatives, the Korn and Z shells), along with some
++* specialised kinds of shell scripts (Gentoo ebuilds and eclasses).
+ */
+
+ /*
+@@ -102,7 +103,7 @@
+ extern parserDefinition* ShParser (void)
+ {
+ static const char *const extensions [] = {
+- "sh", "SH", "bsh", "bash", "ksh", "zsh", NULL
++ "sh", "SH", "bsh", "bash", "ksh", "zsh", "ebuild", "eclass", NULL
+ };
+ parserDefinition* def = parserNew ("Sh");
+ def->kinds = ShKinds;
diff --git a/dev-util/ctags/files/ctags-5.8-ada.patch b/dev-util/ctags/files/ctags-5.8-ada.patch
new file mode 100644
index 000000000000..48ed96f0d88e
--- /dev/null
+++ b/dev-util/ctags/files/ctags-5.8-ada.patch
@@ -0,0 +1,28 @@
+--- parsers-orig.h 2009-11-16 23:39:49.747328066 +0200
++++ parsers.h 2009-11-16 23:40:26.541581805 +0200
+@@ -16,6 +16,7 @@
+
+ /* Add the name of any new parser definition function here */
+ #define PARSER_LIST \
++ AdaParser, \
+ AntParser, \
+ AsmParser, \
+ AspParser, \
+--- source-orig.mak 2009-11-16 23:41:17.184586699 +0200
++++ source.mak 2009-11-16 23:41:48.358331136 +0200
+@@ -8,6 +8,7 @@
+ strlist.h vstring.h
+
+ SOURCES = \
++ ada.c \
+ args.c \
+ ant.c \
+ asm.c \
+@@ -70,6 +71,7 @@
+ REGEX_HEADERS = gnu_regex/regex.h
+
+ OBJECTS = \
++ ada.$(OBJEXT) \
+ args.$(OBJEXT) \
+ ant.$(OBJEXT) \
+ asm.$(OBJEXT) \
diff --git a/dev-util/ctags/files/ctags-5.8-f95-pointers.patch b/dev-util/ctags/files/ctags-5.8-f95-pointers.patch
new file mode 100644
index 000000000000..4ac9560f8785
--- /dev/null
+++ b/dev-util/ctags/files/ctags-5.8-f95-pointers.patch
@@ -0,0 +1,12 @@
+--- fortran-orig.c 2009-11-16 23:38:06.154328652 +0200
++++ fortran.c 2009-11-16 23:38:08.711335501 +0200
+@@ -1319,7 +1319,8 @@
+ readToken (token);
+ skipPast (token, TOKEN_OPERATOR);
+ }
+- else if (strcmp (vStringValue (token->string), "=") == 0)
++ else if ((strcmp (vStringValue (token->string), "=") == 0) ||
++ (strcmp (vStringValue (token->string), "=>") == 0))
+ {
+ while (! isType (token, TOKEN_COMMA) &&
+ ! isType (token, TOKEN_STATEMENT_END))
diff --git a/dev-util/ctags/files/ctags-5.8-python-vars-starting-with-def.patch b/dev-util/ctags/files/ctags-5.8-python-vars-starting-with-def.patch
new file mode 100644
index 000000000000..83d9f7e887eb
--- /dev/null
+++ b/dev-util/ctags/files/ctags-5.8-python-vars-starting-with-def.patch
@@ -0,0 +1,13 @@
+--- python-orig.c 2009-11-16 23:33:44.930351712 +0200
++++ python.c 2009-11-16 23:35:08.433328150 +0200
+@@ -264,8 +264,8 @@
+ while (*cp)
+ {
+ cp = skipEverything (cp);
+- if (!strncmp(cp, "def", 3) || !strncmp(cp, "class", 5) ||
+- !strncmp(cp, "cdef", 4) || !strncmp(cp, "cpdef", 5))
++ if (!strncmp(cp, "def ", 4) || !strncmp(cp, "class ", 6) ||
++ !strncmp(cp, "cdef ", 5) || !strncmp(cp, "cpdef ", 6))
+ {
+ return cp;
+ }
diff --git a/dev-util/ctags/metadata.xml b/dev-util/ctags/metadata.xml
new file mode 100644
index 000000000000..3b8ef2c5908b
--- /dev/null
+++ b/dev-util/ctags/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <use>
+ <flag name="ada">Enable Ada support</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">gnuada</remote-id>
+ </upstream>
+</pkgmetadata>