summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-29 23:16:29 +0100
committerSam James <sam@gentoo.org>2022-08-29 23:16:56 +0100
commit7990e93e5706a4d46c81d6af5707fd3dee8314d9 (patch)
tree13474b8bcde446f8830e93b6c19aa42e959e157e /dev-util/ctags
parentmedia-libs/ampache_browser: Stabilize 1.0.4 x86, #867304 (diff)
downloadgentoo-7990e93e5706a4d46c81d6af5707fd3dee8314d9.tar.gz
gentoo-7990e93e5706a4d46c81d6af5707fd3dee8314d9.tar.bz2
gentoo-7990e93e5706a4d46c81d6af5707fd3dee8314d9.zip
dev-util/ctags: add 20220828.0
Some improvements to Geany bits which might help w/ the test failure? (Not that I could hit it anyway.) Bug: https://bugs.gentoo.org/833276 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/ctags')
-rw-r--r--dev-util/ctags/Manifest1
-rw-r--r--dev-util/ctags/ctags-20220828.0.ebuild79
-rw-r--r--dev-util/ctags/ctags-99999999.ebuild26
3 files changed, 94 insertions, 12 deletions
diff --git a/dev-util/ctags/Manifest b/dev-util/ctags/Manifest
index 55fc994461a2..8e9fd7251f04 100644
--- a/dev-util/ctags/Manifest
+++ b/dev-util/ctags/Manifest
@@ -1,2 +1,3 @@
DIST ctags-20190331.tar.gz 1537104 BLAKE2B 354ddf48cdc9421e70d9d37ec7251e51f7f78564dc4f6236d12e2e18519369c39c22585830fd301b7eff4898d550b824776541198b8c4a31425711776b14fde4 SHA512 414faef7628ecaa66fcd5f172781a32194e1d58637dded1f7e55c138239ad777796bb1510bd447af3ad8243b7178e6f4859139305b0c0efe298182408f34524c
DIST ctags-20211017.0.tar.gz 2542128 BLAKE2B cade7149cb2fd0645f9b7ecd37c8b9acdeae7037fde2bb74aa94d67f04963327429b83dcf5cd658f082bd8ce4c407f69f4924da5f768bec029b4075997bbd882 SHA512 85bfb4d40c1d9045b4ba4dc280ee7108ee2fd4572c92794d5bdc854f3511dad1ecf282428e61161773f7bfaca725d774593a0e83fc767a1bb2e12b229a19bec0
+DIST ctags-20220828.0.tar.gz 2952276 BLAKE2B 2ec3a01646cfb89446604af65387bb5cbf17188177505000f5803a9a535f59799961e8144d3ab36b23114fc093cb487589f52e7186b60041ff3bf2a439f77dab SHA512 4c1289dab24edded85c7ae31c06b0cad5b8f08f7f709a0bdacdf5f9d8ccf722c820d6fef6d46298bb06c48256e80f594dbf2456b91d1c50b3509ce4d3fe3ae9c
diff --git a/dev-util/ctags/ctags-20220828.0.ebuild b/dev-util/ctags/ctags-20220828.0.ebuild
new file mode 100644
index 000000000000..96335dde5149
--- /dev/null
+++ b/dev-util/ctags/ctags-20220828.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Exuberant Ctags creates tags files for code browsing in editors"
+HOMEPAGE="https://ctags.io/ https://github.com/universal-ctags/ctags"
+
+if [[ ${PV} == *99999999* ]] ; then
+ EGIT_REPO_URI="https://github.com/universal-ctags/ctags"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/universal-ctags/ctags/archive/refs/tags/p5.9.${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-p5.9.${PV}
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="json pcre2 xml yaml"
+
+DEPEND="
+ json? ( dev-libs/jansson:= )
+ pcre2? ( dev-libs/libpcre2 )
+ xml? ( dev-libs/libxml2:2 )
+ yaml? ( dev-libs/libyaml )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-python/docutils
+ virtual/pkgconfig
+"
+IDEPEND="app-eselect/eselect-ctags"
+
+src_prepare() {
+ # Ignore check-genfile test (calls git which errors out)
+ sed -i 's/man-test check-genfile/man-test/' makefiles/testing.mak || die
+
+ default
+
+ #./misc/dist-test-cases > makefiles/test-cases.mak || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable json) \
+ $(use_enable pcre2) \
+ $(use_enable xml) \
+ $(use_enable yaml) \
+ --disable-etags \
+ --enable-tmpdir="${EPREFIX}"/tmp
+}
+
+src_install() {
+ emake prefix="${ED}"/usr mandir="${ED}"/usr/share/man install
+
+ # Namepace collision with X/Emacs-provided /usr/bin/ctags -- we
+ # rename ctags to exuberant-ctags (Mandrake does this also).
+ mv "${ED}"/usr/bin/{ctags,exuberant-ctags} || die
+ mv "${ED}"/usr/share/man/man1/{ctags,exuberant-ctags}.1 || die
+}
+
+pkg_postinst() {
+ eselect ctags update
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "You can set the version to be started by ${EROOT}/usr/bin/ctags through"
+ elog "the ctags eselect module. \"man ctags.eselect\" for details."
+ fi
+}
+
+pkg_postrm() {
+ eselect ctags update
+}
diff --git a/dev-util/ctags/ctags-99999999.ebuild b/dev-util/ctags/ctags-99999999.ebuild
index 3b3948787072..96335dde5149 100644
--- a/dev-util/ctags/ctags-99999999.ebuild
+++ b/dev-util/ctags/ctags-99999999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,32 +7,33 @@ inherit autotools
DESCRIPTION="Exuberant Ctags creates tags files for code browsing in editors"
HOMEPAGE="https://ctags.io/ https://github.com/universal-ctags/ctags"
+
if [[ ${PV} == *99999999* ]] ; then
- inherit git-r3
EGIT_REPO_URI="https://github.com/universal-ctags/ctags"
+ inherit git-r3
else
SRC_URI="https://github.com/universal-ctags/ctags/archive/refs/tags/p5.9.${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${PN}-p5.9.${PV}"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ S="${WORKDIR}"/${PN}-p5.9.${PV}
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="GPL-2+"
SLOT="0"
-IUSE="json xml yaml"
+IUSE="json pcre2 xml yaml"
DEPEND="
json? ( dev-libs/jansson:= )
+ pcre2? ( dev-libs/libpcre2 )
xml? ( dev-libs/libxml2:2 )
yaml? ( dev-libs/libyaml )
"
-RDEPEND="
- ${DEPEND}
- app-eselect/eselect-ctags
-"
+RDEPEND="${DEPEND}"
BDEPEND="
dev-python/docutils
virtual/pkgconfig
"
+IDEPEND="app-eselect/eselect-ctags"
src_prepare() {
# Ignore check-genfile test (calls git which errors out)
@@ -48,6 +49,7 @@ src_prepare() {
src_configure() {
econf \
$(use_enable json) \
+ $(use_enable pcre2) \
$(use_enable xml) \
$(use_enable yaml) \
--disable-etags \
@@ -57,7 +59,7 @@ src_configure() {
src_install() {
emake prefix="${ED}"/usr mandir="${ED}"/usr/share/man install
- # namepace collision with X/Emacs-provided /usr/bin/ctags -- we
+ # Namepace collision with X/Emacs-provided /usr/bin/ctags -- we
# rename ctags to exuberant-ctags (Mandrake does this also).
mv "${ED}"/usr/bin/{ctags,exuberant-ctags} || die
mv "${ED}"/usr/share/man/man1/{ctags,exuberant-ctags}.1 || die
@@ -66,8 +68,8 @@ src_install() {
pkg_postinst() {
eselect ctags update
- if [[ -z "$REPLACING_VERSIONS" ]]; then
- elog "You can set the version to be started by /usr/bin/ctags through"
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "You can set the version to be started by ${EROOT}/usr/bin/ctags through"
elog "the ctags eselect module. \"man ctags.eselect\" for details."
fi
}