summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-02-26 02:26:03 +0200
committerMart Raudsepp <leio@gentoo.org>2019-02-26 02:26:03 +0200
commitd89a549053d0d59d945b90c00e0d86ece871a0d8 (patch)
tree9665b56a99a58252b314256879b0942c7f5cbc9b /dev-util/d-feet
parentapp-editors/notepadqq: Fix build with Qt 5.11 (diff)
downloadgentoo-d89a549053d0d59d945b90c00e0d86ece871a0d8.tar.gz
gentoo-d89a549053d0d59d945b90c00e0d86ece871a0d8.tar.bz2
gentoo-d89a549053d0d59d945b90c00e0d86ece871a0d8.zip
dev-util/d-feet: bump to 0.3.14
Includes various ebuild simplifications and fixes: * UPDATE_DESKTOP avoidance not needed, upstream has had a DESTDIR check in there for a while now. * 0.3.14 moved from pep8 to preferring the new name of pycodestyle; instead of updating the sed, just add the dependency now, as the whitespace tests actually pass upstream now, unlike in 0.3.13. * Downgrade dep from yelp-tools to itstool, as we don't call eautoreconf * Fix LICENSE to have or-later * Remove error throwing python_fix_shebang call - not sure why it errors now on not finding anything to fix, but at least in 0.3.14 it's unnecessary anyways, as $PYTHON from ebuild env is properly honored and the relevant shebangs are correct without any manual fixing. Closes: https://bugs.gentoo.org/678768 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-util/d-feet')
-rw-r--r--dev-util/d-feet/Manifest1
-rw-r--r--dev-util/d-feet/d-feet-0.3.14.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/d-feet/Manifest b/dev-util/d-feet/Manifest
index 8ff5b1fa8b22..77f4fd18e479 100644
--- a/dev-util/d-feet/Manifest
+++ b/dev-util/d-feet/Manifest
@@ -1 +1,2 @@
DIST d-feet-0.3.13.tar.xz 174700 BLAKE2B 66d2a8735011c64985889edf1acbb37e1547d6af52fc6499124ffae09d8cfd876051e12f231c26a1af848939b9a3e9c36d1083e8afb240575d4f580ea92fde65 SHA512 b5a4eb995e883406a13e8a4137b1ed751cfbfd0fd80fa26eb81cf6f8b69bca63f3a4ad940b1aeaed0a57d48d81c582b62f6c3880e7038136f2b40a1eef25328f
+DIST d-feet-0.3.14.tar.xz 177064 BLAKE2B be1150cead543dab3daf1c8beae4047d3c32e60dbf9a73a50ef95fe62cbafbf6af9ab174c7f9128212b0d33aa111545b598c6aab6d359625c94f0029ca5f1a20 SHA512 1ea3bd2251693884592d375f1459681043b5185c341299dc28cbc8e4e05f3ff3a423c051b650806f6b930d8b89e0d751983ada7ad9a74b380f74f3205125b1b4
diff --git a/dev-util/d-feet/d-feet-0.3.14.ebuild b/dev-util/d-feet/d-feet-0.3.14.ebuild
new file mode 100644
index 000000000000..af1ae4c4c6d0
--- /dev/null
+++ b/dev-util/d-feet/d-feet-0.3.14.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit gnome2 python-single-r1 virtualx
+
+DESCRIPTION="D-Feet is a powerful D-Bus debugger"
+HOMEPAGE="https://wiki.gnome.org/Apps/DFeet"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test +X"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ >=x11-libs/gtk+-3.9.4:3[introspection]
+ >=dev-libs/gobject-introspection-0.9.6:=
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ >=dev-libs/glib-2.34:2
+ >=dev-python/pygobject-3.3.91:3[${PYTHON_USEDEP}]
+ >=sys-apps/dbus-1
+ X? ( x11-libs/libwnck:3[introspection] )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-util/itstool
+ >=dev-util/intltool-0.40.0
+ test? ( dev-python/pycodestyle )
+" # eautoreconf needs yelp-tools
+
+src_configure() {
+ # Tests are only python pep8 whitespace checking and intltool checks - checking python whitespate style is not useful for us
+ gnome2_src_configure \
+ $(use_enable test tests)
+}
+
+src_test() {
+ virtx default
+}