summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/deskzilla/deskzilla-1.7.1-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/deskzilla/deskzilla-1.7.1-r1.ebuild')
-rw-r--r--dev-util/deskzilla/deskzilla-1.7.1-r1.ebuild92
1 files changed, 92 insertions, 0 deletions
diff --git a/dev-util/deskzilla/deskzilla-1.7.1-r1.ebuild b/dev-util/deskzilla/deskzilla-1.7.1-r1.ebuild
new file mode 100644
index 000000000000..9f41c34a37ce
--- /dev/null
+++ b/dev-util/deskzilla/deskzilla-1.7.1-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit java-pkg-2 versionator
+
+DESCRIPTION="A desktop client for Mozilla's Bugzilla bug tracking system"
+HOMEPAGE="http://almworks.com/deskzilla"
+
+MY_PV=$(replace_all_version_separators '_') #${PV/beta/b})
+MY_P="${PN}-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
+SRC_URI="http://d1.almworks.com/.files/${MY_P}_without_jre.tar.gz
+ http://dev.gentoo.org/~ercpe/distfiles/${CATEGORY}/${PN}/deskzilla_gentoo.license"
+LICENSE="ALMWorks-1.2"
+# license does not allow redistributing, and they seem to silently update
+# distfiles...
+RESTRICT="mirror"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=virtual/jre-1.5
+ dev-java/picocontainer:1
+ dev-java/javolution:4
+ >=dev-java/commons-codec-1.3
+ >=dev-java/jgoodies-forms-1.0.7
+ >=dev-java/commons-logging-1.0.4
+ >=dev-java/xmlrpc-2.0.1
+ dev-java/xerces:2
+ dev-java/itext:0
+ dev-java/jazzy:0"
+
+src_unpack() {
+ unpack ${A}
+ # Remove external unaltered bundled jars
+ local lib="${S}/lib"
+ local liborig="${S}/lib.orig"
+ mv ${lib} ${liborig} || die
+ mkdir ${lib} || die
+ # They've patched commons-httpclient (was version 3.0)
+ mv ${liborig}/commons-httpclient.jar ${lib} || die
+ # They've patched nekohtml (was version 0.9.5)
+ mv ${liborig}/nekohtml.jar ${lib} || die
+ # Also jdom (was 1.0), soon they will patch everything and we will just unpack, yay
+ mv ${liborig}/pjdom.jar ${lib} || die
+ # Almworks proprietary lib
+ mv ${liborig}/almworks-tracker-api.jar ${lib} || die
+ # IntelliJ IDEA proprietary lib
+ mv ${liborig}/forms_rt.jar ${lib} || die
+ # God knows what's this. Anyway, proprietary.
+ mv ${liborig}/twocents.jar ${lib} || die
+ rm -rf ${liborig} || die
+}
+
+src_install () {
+ local dir="/opt/${PN}"
+
+ insinto "${dir}"
+ doins -r components etc license lib log deskzilla.url
+ insinto "${dir}/license"
+ doins "${DISTDIR}"/deskzilla_gentoo.license
+
+ java-pkg_jarinto "${dir}"
+ java-pkg_dojar ${PN}.jar
+ local dep="xerces-2,picocontainer-1,commons-logging,commons-codec"
+ dep+=",jgoodies-forms,javolution-4,xmlrpc,itext,jazzy"
+ java-pkg_register-dependency ${dep}
+ java-pkg_dolauncher ${PN} --main "com.almworks.launcher.Launcher" --java_args "-Xmx256M"
+
+ newdoc README.txt README || die
+ newdoc RELEASE.txt RELEASE || die
+
+ doicon deskzilla.png
+ make_desktop_entry deskzilla "Deskzilla" deskzilla "Development"
+}
+
+pkg_postinst() {
+ elog "The default, evaluation license allows usage for one month."
+ elog "You may switch (per-user) to the license we obtained for Gentoo,"
+ elog "located in /opt/${PN}/license/${PN}_gentoo.license"
+ elog "It is locked to Gentoo, ALM Works and Mozilla bugzilla only."
+ elog "Note that you need to use 1.5 VM to run deskzilla when setting"
+ elog "license or it won't get set due to bug in 1.6+ VMs."
+ elog
+ elog "If you are going to use Deskzilla for an open source project,"
+ elog "you can similarly request your own free license:"
+ elog "http://almworks.com/opensource.html?product=deskzilla"
+}